mac80211: respect user-set regulatory domain by default
authorDaniel Golle <daniel@makrotopia.org>
Wed, 25 May 2016 17:32:01 +0000 (19:32 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 5 Jun 2016 11:37:55 +0000 (13:37 +0200)
It turns out most device vendors don't set the correct country code
in their devices' on-flash-EEPROM sections as they apparently rather
provide a complete per-target-market firmware with patched drivers
instead of just setting the country code.
This results in the driver to incorrectly assume the value stored in
the on-flash-EERPOM (usually US or China) being the regulatory domain
inside which the device is being used.
To work around this issue, OpenWrt introduced the ATH_USER_REGD config
variable to decide during build whether or not to allow the user to
override the regulatory domain setting. This option, however, is not
enabled by default and thus ends up being disabled for snapshots builds
and released binaries.
As we know for a long time that most devices got borked regulatory
domain values set in their EEPROMs we should allow our users to respect
their local law (instead of just assume US or China laws).
Note that also the current default has great potential of users not
ever setting their regulatory domain and thus using inapproriate and
potentially illegal frequencies and/or tx-power settings

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mac80211/Makefile

index 340ea38180972c1c522ff5486251f7b33c7e6c31..acd5e283dcb1e0b38e5cdd7c9578ec5c746917da 100644 (file)
@@ -161,6 +161,7 @@ define KernelPackage/ath/config
   if PACKAGE_kmod-ath
        config ATH_USER_REGD
                bool "Force Atheros drivers to respect the user's regdomain settings"
+               default y
                help
                  Atheros' idea of regulatory handling is that the EEPROM of the card defines
                  the regulatory limits and the user is only allowed to restrict the settings