kernel: bump 5.4 to 5.4.138
authorJohn Audia <graysky@archlinux.us>
Wed, 4 Aug 2021 11:55:58 +0000 (07:55 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Aug 2021 15:57:34 +0000 (17:57 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/backport-5.4/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/mvebu/patches-5.4/801-pci-mvebu-time-out-reset-on-link-up.patch

index 54e10af9a33998e4a5a1730a20cc149f2c495e7b..3ef1aba6c39d069c8e6aed4fc610aea74ca4e303 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .137
+LINUX_VERSION-5.4 = .138
 LINUX_VERSION-5.10 = .56
 
-LINUX_KERNEL_HASH-5.4.137 = f09e5e366ce5d8bde887cda229ef17138fd1653706a702221f934f99aaa31f7c
+LINUX_KERNEL_HASH-5.4.138 = a43957727a54e5e1035d7372a1e64203ae8e3060c52a3816916157967f9a8657
 LINUX_KERNEL_HASH-5.10.56 = 4d6a0d5f9c50fa44890e0b61e1fb63f6efe6be448ceddfe1ad7c0cbd2890ec6b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 9bcb33b737eb83d29d036c429a93b0868c190dcf..bf89af3840f43cd09b95dcccbdff6e9b9a85dda1 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -1207,18 +1207,6 @@ static bool gc_worker_can_early_drop(con
+@@ -1212,18 +1212,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1255,10 +1243,8 @@ static void gc_worker(struct work_struct
+@@ -1260,10 +1248,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 4058dc8ed58e3fbd34493d1090b8d28e527c1545..49ea3de0d13e3304dbb1a1a28b7849ad0ab514af 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/pci/controller/pci-mvebu.c
 +++ b/drivers/pci/controller/pci-mvebu.c
-@@ -928,6 +928,7 @@ static int mvebu_pcie_powerup(struct mve
+@@ -936,6 +936,7 @@ static int mvebu_pcie_powerup(struct mve
  
        if (port->reset_gpio) {
                u32 reset_udelay = PCI_PM_D3COLD_WAIT * 1000;
@@ -21,7 +21,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  
                of_property_read_u32(port->dn, "reset-delay-us",
                                     &reset_udelay);
-@@ -935,7 +936,13 @@ static int mvebu_pcie_powerup(struct mve
+@@ -943,7 +944,13 @@ static int mvebu_pcie_powerup(struct mve
                udelay(100);
  
                gpiod_set_value_cansleep(port->reset_gpio, 0);
@@ -36,7 +36,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        }
  
        return 0;
-@@ -1099,15 +1106,16 @@ static int mvebu_pcie_probe(struct platf
+@@ -1107,15 +1114,16 @@ static int mvebu_pcie_probe(struct platf
                if (!child)
                        continue;