brcm2708: add support for Raspberry Pi 2B 1.2
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 19 Sep 2019 15:32:44 +0000 (17:32 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 19 Sep 2019 15:38:18 +0000 (17:38 +0200)
RPi 2B 1.2 has a BCM2710/BCM2837 like RPi 3 devices.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/brcm2708/base-files/etc/board.d/02_network
target/linux/brcm2708/base-files/lib/preinit/05_set_preinit_iface_brcm2708
target/linux/brcm2708/image/Makefile

index 33aa15d85e989dd81fb0476317356e6e39fd1543..36c8c5df1afaaaa8675a7f152970bc5f923dacec 100755 (executable)
@@ -15,6 +15,7 @@ raspberrypi,model-b |\
 raspberrypi,model-b-plus |\
 raspberrypi,model-b-rev2 |\
 raspberrypi,2-model-b |\
+raspberrypi,2-model-b-rev2 |\
 raspberrypi,3-model-b |\
 raspberrypi,3-model-b-plus |\
 raspberrypi,4-model-b)
index bbb95149c2c926ad345f463dc5cb9e678276db9e..de221ae7ad381141c7f54de16fc82172b48d047c 100644 (file)
@@ -7,6 +7,7 @@ set_preinit_iface() {
 
        case "$(board_name)" in
        raspberrypi,2-model-b |\
+       raspberrypi,2-model-b-rev2 |\
        raspberrypi,3-model-b |\
        raspberrypi,3-model-b-plus |\
        raspberrypi,4-model-b |\
index 01d1bf585f3f4089db11529654c23df3ed729cfd..db2b3b55621844e2643ec8841b473f3cc8d48f2c 100644 (file)
@@ -72,7 +72,10 @@ endef
 
 define Device/rpi
   DEVICE_MODEL := B/B+/CM/Zero/ZeroW
-  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-zero bcm2708-rpi-zero-w
+  DEVICE_DTS := \
+       bcm2708-rpi-b bcm2708-rpi-b-plus \
+       bcm2708-rpi-cm \
+       bcm2708-rpi-zero bcm2708-rpi-zero-w
   SUPPORTED_DEVICES := \
        rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w \
        raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,model-b-rev2 \
@@ -89,10 +92,14 @@ endif
 
 define Device/rpi-2
   DEVICE_MODEL := 2B/3B/3B+/3CM/4B
-  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2711-rpi-4-b bcm2710-rpi-cm3
+  DEVICE_DTS := \
+       bcm2709-rpi-2-b bcm2710-rpi-2-b \
+       bcm2710-rpi-3-b bcm2710-rpi-3-b-plus \
+       bcm2711-rpi-4-b \
+       bcm2710-rpi-cm3
   SUPPORTED_DEVICES := \
        rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
-       raspberrypi,2-model-b \
+       raspberrypi,2-model-b raspberrypi,2-model-b-rev2 \
        raspberrypi,3-model-b raspberrypi,3-model-b-plus \
        raspberrypi,3-compute-module raspberrypi,compute-module-3 \
        raspberrypi,4-model-b
@@ -110,11 +117,15 @@ ifeq ($(SUBTARGET),bcm2709)
 endif
 
 define Device/rpi-3
-  DEVICE_MODEL := 3B/3B+/3CM
+  DEVICE_MODEL := 2B-1.2/3B/3B+/3CM
   KERNEL_IMG := kernel8.img
-  DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus broadcom/bcm2710-rpi-cm3
+  DEVICE_DTS := \
+       broadcom/bcm2710-rpi-2-b \
+       broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus \
+       broadcom/bcm2710-rpi-cm3
   SUPPORTED_DEVICES := \
        rpi-3-b rpi-3-b-plus \
+       raspberrypi,2-model-b-rev2 \
        raspberrypi,3-model-b raspberrypi,3-model-b-plus \
        raspberrypi,3-compute-module raspberrypi,compute-module-3
   DEVICE_PACKAGES := \