kernel: bump kernel 4.4 to version 4.4.140
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 13 Jul 2018 18:54:11 +0000 (20:54 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 13 Jul 2018 19:25:14 +0000 (21:25 +0200)
These two patches:
        target/linux/ar71xx/patches-4.4/403-mtd_fix_cfi_cmdset_0002_status_check.patch
        target/linux/ramips/patches-4.4/0036-mtd-fix-cfi-cmdset-0002-erase-status-check.patch
are replaced by upstream commit 242dbd2b3df ("mtd: cfi_cmdset_0002:
Change erase functions to check chip good only")

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-4.4/411-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch
target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/ramips/patches-4.4/0036-mtd-fix-cfi-cmdset-0002-erase-status-check.patch [deleted file]
target/linux/ramips/patches-4.4/0037-mtd-cfi-cmdset-0002-force-word-write.patch

index 6b2c76d71fddf5375c91231803a8ffe259da2504..39d17efae57befd27b1609207210f9da33fa3f5d 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .139
+LINUX_VERSION-4.4 = .140
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.139 = b66055d4208d4a6fbee73065cd2b576d095b98ea8618f9b4eb952e18d3d6ed45
+LINUX_KERNEL_HASH-4.4.140 = 184c8f3cde0caca0d2a15ee2b6ce47e3a5b57038bc15a65e631d6b340886c7bb
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 8f41d9432cb98eda80b5cce24c3b34123221b255..040d83d4cb70ce25b8bbb329e104613e9da298fd 100644 (file)
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2228,7 +2230,6 @@ static int cfi_amdstd_panic_write(struct
-       return 0;
- }
--
- /*
-  * Handle devices with one erase region, that only implement
-  * the chip erase command.
-@@ -2293,8 +2294,8 @@ static int __xipram do_erase_chip(struct
-                       chip->erase_suspended = 0;
-               }
--              if (chip_ready(map, adr))
--                      break;
-+              if (chip_good(map, adr, map_word_ff(map)))
-+                      goto op_done;
-               if (time_after(jiffies, timeo)) {
-                       printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2314,6 +2315,7 @@ static int __xipram do_erase_chip(struct
-               ret = -EIO;
-       }
-+ op_done:
-       chip->state = FL_READY;
-       xip_enable(map, chip, adr);
-       DISABLE_VPP(map);
-@@ -2383,9 +2385,9 @@ static int __xipram do_erase_oneblock(st
-                       chip->erase_suspended = 0;
-               }
--              if (chip_ready(map, adr)) {
-+              if (chip_good(map, adr, map_word_ff(map))) {
-                       xip_enable(map, chip, adr);
--                      break;
-+                      goto op_done;
-               }
-               if (time_after(jiffies, timeo)) {
-@@ -2407,6 +2409,7 @@ static int __xipram do_erase_oneblock(st
-               ret = -EIO;
-       }
-+ op_done:
-       chip->state = FL_READY;
-       DISABLE_VPP(map);
-       put_chip(map, chip, adr);
index 28c6ad875d17d68a9c31b4f6f8022ecaf3b7825b..b28d6c1c2d2475c40f6f3045712e807f835eaee7 100644 (file)
@@ -7,7 +7,7 @@
 -#define FORCE_WORD_WRITE 0
 +#define FORCE_WORD_WRITE 1
  
- #define MAX_WORD_RETRIES 3
+ #define MAX_RETRIES 3
  
 @@ -51,7 +51,9 @@
  
index bdb38a0e242e79e5aefc7cd8e2cab3e9f603b057..c7f43fe14fa8d2c457f5cabde25c68640c49ed29 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6831,8 +6831,6 @@ int alloc_contig_range(unsigned long sta
+@@ -6829,8 +6829,6 @@ int alloc_contig_range(unsigned long sta
  
        /* Make sure the range is really isolated. */
        if (test_pages_isolated(outer_start, end, false)) {
index a53be2d15cad538df9ddc2e55869e7e5dd35fe56..dfdee8b5ced934d8fca6b773f6825e0bee0c34fb 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -5372,7 +5372,7 @@ static void __init_refok alloc_node_mem_
+@@ -5370,7 +5370,7 @@ static void __init_refok alloc_node_mem_
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
diff --git a/target/linux/ramips/patches-4.4/0036-mtd-fix-cfi-cmdset-0002-erase-status-check.patch b/target/linux/ramips/patches-4.4/0036-mtd-fix-cfi-cmdset-0002-erase-status-check.patch
deleted file mode 100644 (file)
index 1bcad6d..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 8e72a3a1be8f6328bd7ef491332ba541547b6086 Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Mon, 15 Jul 2013 00:38:51 +0200
-Subject: [PATCH 36/53] mtd: fix cfi cmdset 0002 erase status check
-
----
- drivers/mtd/chips/cfi_cmdset_0002.c |    4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -2293,7 +2293,7 @@ static int __xipram do_erase_chip(struct
-                       chip->erase_suspended = 0;
-               }
--              if (chip_ready(map, adr))
-+              if (chip_good(map, adr, map_word_ff(map)))
-                       break;
-               if (time_after(jiffies, timeo)) {
-@@ -2383,7 +2383,7 @@ static int __xipram do_erase_oneblock(st
-                       chip->erase_suspended = 0;
-               }
--              if (chip_ready(map, adr)) {
-+              if (chip_good(map, adr, map_word_ff(map))) {
-                       xip_enable(map, chip, adr);
-                       break;
-               }
index f6b05a56e7aafe083b2b0f8fd6cd501c087ba2d5..767fa6102ee462bb302158779bd580c316e6e525 100644 (file)
@@ -16,7 +16,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
 -#define FORCE_WORD_WRITE 0
 +#define FORCE_WORD_WRITE 1
  
- #define MAX_WORD_RETRIES 3
+ #define MAX_RETRIES 3
  
 @@ -51,7 +51,9 @@