kernel: bump 5.4 to 5.4.90
authorJohn Audia <graysky@archlinux.us>
Sun, 17 Jan 2021 14:15:14 +0000 (09:15 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 14:39:36 +0000 (15:39 +0100)
All modification made by update_kernel.sh in a fresh clone without
existing toolchains.

Build system: x86_64
Build-tested: ipq806x/R7800, bcm27xx/bcm2711
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
Tested-by: Curtis Deptuck <curtdept@me.com> [x86/64]
include/kernel-version.mk
target/linux/generic/hack-5.4/221-module_exports.patch
target/linux/mediatek/patches-5.4/0600-net-phylink-propagate-resolved-link-config-via-mac_l.patch
target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch

index 8b2577961c5e575dc73146a28fa07c59858dd8ac..acd651f9ed46d9ed525d593fcfc20b3ce7c5e348 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .89
+LINUX_VERSION-5.4 = .90
 
-LINUX_KERNEL_HASH-5.4.89 = 268dd5177b6df1867d4ed2452ffb11a016d955c43aba5e07940886f347ab0aaf
+LINUX_KERNEL_HASH-5.4.90 = 646736bc063f181c22648934f0dc3d97d49aec6edfd7358d2fe3df29fb66fa1a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index f651cd902e90b2a3f12b4a0dc64cc9577791f2f7..4f805cf7e3dd6beb27ad44978782cd692e3221c5 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -885,6 +895,8 @@
+@@ -888,6 +898,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
index 0c9ef86a3b262930156c485756e7f8117ac99da0..fc987e8e9d3586d6912435c835449c62a8fa1dc6 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
  
        netif_tx_start_all_queues(port->dev);
-@@ -5127,8 +5131,11 @@ static void mvpp2_mac_config(struct phyl
+@@ -5139,8 +5143,11 @@ static void mvpp2_mac_config(struct phyl
        mvpp2_port_enable(port);
  }
  
index ef6f66e3fc0094243c63a444cdd0768c57c758cb..7a34dbad6e76b6fc03f1dda8be13086421537ebc 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct ethtool_eee *p = &priv->dev->ports[port].eee;
 --- a/drivers/net/dsa/lantiq_gswip.c
 +++ b/drivers/net/dsa/lantiq_gswip.c
-@@ -1507,7 +1507,9 @@ static void gswip_phylink_mac_link_down(
+@@ -1508,7 +1508,9 @@ static void gswip_phylink_mac_link_down(
  static void gswip_phylink_mac_link_up(struct dsa_switch *ds, int port,
                                      unsigned int mode,
                                      phy_interface_t interface,