octeon: disable edgerouter image
authorJohannes Kimmel <fff@bareminimum.eu>
Thu, 29 Oct 2020 10:07:38 +0000 (11:07 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 30 Oct 2020 18:26:09 +0000 (19:26 +0100)
This patch disables the image for edgerouter devices by default, since
it isn't able to boot at the moment.

Currently the edgerouter image won't boot. Current kernels have an
option CONFIG_CAVIUM_CN63XXP1 that needs to be enabled for this chip.

If the kernel was compiled without this option, following message is
displayed and the machine reboots:

[   36.778028] Kernel panic - not syncing: OCTEON II DCache prefetch workaround not in place (cfa0000c).
[   36.778028] Please build kernel with proper options (CONFIG_CAVIUM_CN63XXP1).
[   36.794398] Rebooting in 1 seconds..

This was last confirmed on 2020-10-29.

The description of this option states, that enabling it will possibly
cause performance issues on other chips.

Signed-off-by: Johannes Kimmel <fff@bareminimum.eu>
target/linux/octeon/image/Makefile

index 1dbb60edbcccbf4b2615afa298b046031cd6b585..7851e4a99c203a7b7aaf18416e8add028bdd83be 100644 (file)
@@ -44,6 +44,7 @@ define Device/ubnt_edgerouter
   DEVICE_MODEL := EdgeRouter
   BOARD_NAME := er
   CMDLINE := $(ER_CMDLINE)
+  DEFAULT := n
 endef
 TARGET_DEVICES += ubnt_edgerouter