kernel: bump 5.4 to 5.4.95
authorJohn Audia <graysky@archlinux.us>
Thu, 4 Feb 2021 02:09:56 +0000 (21:09 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 4 Feb 2021 21:07:32 +0000 (22:07 +0100)
Ran update_kernel.sh in a fresh clone without any existing toolchains.

Removed upstreamed patches:
 imx6: 303-ARM-dts-imx6qdl-gw52xx-fix-duplicate-regulator-namin.patch

Build system: x86_64
Build-tested: ipq806x/R7800, bcm27xx/bcm2711
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/imx6/patches-5.4/303-ARM-dts-imx6qdl-gw52xx-fix-duplicate-regulator-namin.patch [deleted file]

index dd3c1bfbf0201f26785ffb23a18180b957267707..e5243089641604756a0904a2d1f357f0ab2bc6b4 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .94
+LINUX_VERSION-5.4 = .95
 
-LINUX_KERNEL_HASH-5.4.94 = c23df57db7312e9afa5ce477046e227a3c2153efbe1f29045ad23c820aad2b39
+LINUX_KERNEL_HASH-5.4.95 = 030ae544f346bfa2ce619dd9e17e93d10ec393632d3b6d6cf5d1fc84b914d449
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index dfc16a7ba119077b65d6bde76abe1c1562357615..c7bcc29372a953969d1756ec0b446541cd48e259 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3973,14 +3973,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3975,14 +3975,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
diff --git a/target/linux/imx6/patches-5.4/303-ARM-dts-imx6qdl-gw52xx-fix-duplicate-regulator-namin.patch b/target/linux/imx6/patches-5.4/303-ARM-dts-imx6qdl-gw52xx-fix-duplicate-regulator-namin.patch
deleted file mode 100644 (file)
index c459e6f..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 069abe403d4eba85eccea16f8b72186a89a68bb1 Mon Sep 17 00:00:00 2001
-From: Koen Vandeputte <koen.vandeputte@ncentric.com>
-Date: Thu, 7 Jan 2021 10:06:03 +0100
-Subject: [PATCH] ARM: dts: imx6qdl-gw52xx: fix duplicate regulator naming
-
-2 regulator descriptions carry identical naming.
-
-This leads to following boot warning:
-[    0.173138] debugfs: Directory 'vdd1p8' with parent 'regulator' already present!
-
-Fix this by renaming the one used for audio.
-
-Fixes: 5051bff33102 ("ARM: dts: imx: ventana: add LTC3676 PMIC support")
-Signed-off-by: Tim Harvey <tharvey@gateworks.com>
-Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-Cc: Fabio Estevam <festevam@gmail.com>
-Cc: Rob Herring <robh+dt@kernel.org>
-Cc: Sascha Hauer <s.hauer@pengutronix.de>
-Cc: Shawn Guo <shawnguo@kernel.org>
-Cc: NXP Linux Team <linux-imx@nxp.com>
-Cc: Pengutronix Kernel Team <kernel@pengutronix.de>
-Cc: stable@vger.kernel.org # v4.11
----
- arch/arm/boot/dts/imx6qdl-gw52xx.dtsi | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
-+++ b/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
-@@ -273,7 +273,7 @@
-                       /* VDD_AUD_1P8: Audio codec */
-                       reg_aud_1p8v: ldo3 {
--                              regulator-name = "vdd1p8";
-+                              regulator-name = "vdd1p8a";
-                               regulator-min-microvolt = <1800000>;
-                               regulator-max-microvolt = <1800000>;
-                               regulator-boot-on;