ramips: rt305x: add support for the Skyline SL-R7205 Wireless 3G router
authorGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 16:44:49 +0000 (16:44 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 16:44:49 +0000 (16:44 +0000)
[juhosg:
- don't switch back to 2.6.39
- update config-3.2
- change machine id to SL-R7205
- reorder case entries in platform scripts
- remove button hotplug script]

Signed-off-by: Haipoh Teoh <hpteoh@ceedtec.com>
SVN-Revision: 30645

14 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-sl-r7205.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39
target/linux/ramips/rt305x/config-3.2

index b167c520bdcd80b67dec7bed6e7fa222f5bdcd1d..26f0d1f0af7a6ebece087de66b7682b1b0fbb93f 100755 (executable)
@@ -69,6 +69,9 @@ get_status_led() {
        rt-n56u)
                status_led="asus:blue:power"
                ;;
+       sl-r7205)
+               status_led="sl-r7205:green:status"
+               ;;
        v11st-fe)
                status_led="v11st-fe:green:status"
                ;;
index 6d90c2597522637ae80fdac7f6a1ad59825e4dd4..eb756a5e5f82a0fce21e2c348d0171d34cbd954c 100644 (file)
@@ -60,6 +60,7 @@ case "$FIRMWARE" in
        omni-emb | \
        rt-n15 | \
        rt-n56u | \
+       sl-r7205 | \
        v11st-fe | \
        v22rw-2x2 | \
        w502u | \
index 891a1a7b3c9bc20c1734002976e280deab4aa95f..d8f3c0cba682816f9b1d0cc198f029e93869ab59 100755 (executable)
@@ -60,6 +60,9 @@ case $board in
        nw718)
                set_usb_led "nw718:amber:usb"
                ;;
+       sl-r7205)
+               set_wifi_led "rt2800pci-phy0::radio"
+               ;;
        v11st-fe)
                set_wifi_led "rt2800pci-phy0::radio"
                ;;
index a36341ca15b4c0b9239f124158fdd7ca337e1b7e..2b8c1ab25461acc9a97db6cdcb3537c5f537c52a 100755 (executable)
@@ -23,6 +23,7 @@ ramips_setup_interfaces()
        argus-atp52b | \
        b2c | \
        nw718 | \
+       sl-r7205 | \
        w502u | \
        wr6202)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
@@ -99,6 +100,7 @@ ramips_setup_macs()
        f5d8235-v1 | \
        nw718 | \
        rt-n15 | \
+       sl-r7205 | \
        wl-351)
                lan_mac=$(ramips_get_mac_binary factory 4)
                wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
index 9f5c02446c3aa6b05c42cefb860813dbae4c29b1..66eb6b98a4eda2fc0dfab0aa9e3b1237c9b3a7bd 100644 (file)
@@ -9,9 +9,10 @@ preinit_set_mac_address() {
 
        case $(ramips_board_name) in
        bc2 |\
+       esr-9753 |\
        nw718 |\
        rt-n56u |\
-       esr-9753)
+       sl-r7205)
                mac=$(ramips_get_mac_binary factory 4)
                mac=$(maccalc or "$mac" "02:00:00:00:00:00")
                ifconfig eth0 hw ether $mac 2>/dev/null
index 07bdf160511405fa9542e667c0cfe65a4cb3d312..728f525d68fe5ab1f7bb9ce32ee41894d6768de6 100755 (executable)
@@ -104,6 +104,9 @@ ramips_board_name() {
        *"RT-N56U")
                name="rt-n56u"
                ;;
+       *"Skyline SL-R7205"*)
+               name="sl-r7205"
+               ;;
        *"Sparklan WCR-150GN")
                name="wcr-150gn"
                ;;
index 2bcfa4b821d57462082c88d4dbd665fa6d45a55e..a2f351353c3b335677d22af2348057558644799d 100755 (executable)
@@ -29,6 +29,7 @@ platform_check_image() {
        rt-g32-b1 | \
        rt-n15 | \
        rt-n56u | \
+       sl-r7205 | \
        w502u |\
        wr6202 |\
        v22rw-2x2 | \
index d6c991133fd25770cbe6a3fb82fc7dd6d816716f..ac7aac4ee0f10dae8005247ec339733fd878f708 100644 (file)
@@ -39,6 +39,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_NBG_419N,           /* ZyXEL NBG-419N */
        RAMIPS_MACH_OMNI_EMB,           /* Omnima MiniEMBWiFi */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
+       RAMIPS_MACH_SL_R7205,           /* Skylink SL-R7205 Wireless 3G Router*/
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_W502U,              /* ALFA Networks W502U */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
index 550287e34f6585c611ac12e094edfe7dac7d3f70..164483222e7d07d293938b7e60848b7539fce416 100644 (file)
@@ -101,6 +101,11 @@ config RT305X_MACH_WL351
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_SL_R7205
+       bool "Skyline SL-R7205 Wireless 3G Router support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_WCR150GN
        bool "Sparklan WCR-150GN support"
        select RALINK_DEV_GPIO_BUTTONS
index da1952c0ee3567301c3ad60f4542e0c2a7fe2ec1..c8b0289e26254b394c81a2561b6e7392b313794d 100644 (file)
@@ -25,6 +25,7 @@ obj-$(CONFIG_RT305X_MACH_NW718)               += mach-nw718.o
 obj-$(CONFIG_RT305X_MACH_OMNI_EMB)     += mach-omni-emb.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
+obj-$(CONFIG_RT305X_MACH_SL_R7205)     += mach-sl-r7205.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_W502U)                += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-sl-r7205.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-sl-r7205.c
new file mode 100644 (file)
index 0000000..9bb429f
--- /dev/null
@@ -0,0 +1,112 @@
+/*
+ *  Skyline SL-R7205 Wireless 3G Router support
+ *
+ *  Copyright (C) 2012 Haipoh Teoh <hpteoh@ceedtec.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define SL_R7205_GPIO_BUTTON_WPS       0
+#define SL_R7205_GPIO_BUTTON_RESET     10      /* active low */
+
+#define SL_R7205_GPIO_LED_WIFI         7
+
+#define SL_R7205_KEYS_POLL_INTERVAL    20
+#define SL_R7205_KEYS_DEBOUNCE_INTERVAL        (3 * SL_R7205_KEYS_POLL_INTERVAL)
+
+static struct mtd_partition sl_r7205_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0a0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x150000,
+               .size   = 0x2b0000,
+       }, {
+               .name   = "firmware",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+
+static struct gpio_led sl_r7205_leds_gpio[] __initdata = {
+       {
+               .name           = "sl-r7205:green:wifi",
+               .gpio           = SL_R7205_GPIO_LED_WIFI,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button sl_r7205_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = SL_R7205_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = SL_R7205_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = SL_R7205_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = SL_R7205_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init sl_r7205_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_flash0_data.nr_parts = ARRAY_SIZE(sl_r7205_partitions);
+       rt305x_flash0_data.parts = sl_r7205_partitions;
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(sl_r7205_leds_gpio),
+                                 sl_r7205_leds_gpio);
+       ramips_register_gpio_buttons(-1, SL_R7205_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(sl_r7205_gpio_buttons),
+                                    sl_r7205_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_SL_R7205, "SL-R7205",
+            "Skyline SL-R7205 Wireless 3G Router",
+            sl_r7205_init);
index 347bafdb76e4c44294498b665cab1fc43cf57cbc..588dfa55fb19076997fe2557d6da0a6025145f4f 100644 (file)
@@ -313,6 +313,10 @@ define Image/Build/Profile/WR5123GN
        $(call Image/Build/Template/GENERIC_8M,$(1),wr512-3gn-8M,WR512-3GN)
 endef
 
+define Image/Build/Profile/SLR7205
+       $(call Image/Build/Template/GENERIC_4M,$(1),sl-r7205,SL-R7205)
+endef
+
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
@@ -327,6 +331,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
+       $(call Image/Build/Profile/SLR7205,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
index ab2bac937934829803e2fa3307a40962404872f6..58b44666ad9948d2525f2cc5c54a9cb2f852eca1 100644 (file)
@@ -107,6 +107,7 @@ CONFIG_RT305X_MACH_NW718=y
 CONFIG_RT305X_MACH_OMNI_EMB=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
+CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_W502U=y
 CONFIG_RT305X_MACH_WCR150GN=y
index 69989c89deed858590e68069987069cfe602b108..04706b4c8ccc0cf2d1bdb325cbeff22fe495bf6d 100644 (file)
@@ -106,6 +106,7 @@ CONFIG_RT305X_MACH_NW718=y
 CONFIG_RT305X_MACH_OMNI_EMB=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
+CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_W502U=y
 CONFIG_RT305X_MACH_WCR150GN=y