kernel: bump 5.4 to 5.4.111
authorJohn Audia <graysky@archlinux.us>
Sat, 10 Apr 2021 13:12:08 +0000 (09:12 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Apr 2021 19:50:08 +0000 (21:50 +0200)
Refreshed with update_kernel.sh. No manual tweaks needed.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/hack-5.4/204-module_strip.patch
target/linux/generic/pending-5.4/203-kallsyms_uncompressed.patch
target/linux/generic/pending-5.4/920-mangle_bootargs.patch

index de67289c6699cf4a61e9f8f981cafbff3702e583..746f75d21240295c376e260c56992f492157de03 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .110
+LINUX_VERSION-5.4 = .111
 LINUX_VERSION-5.10 = .31
 
-LINUX_KERNEL_HASH-5.4.110 = d0f6978440e8a4b266cb1847405a764bca83667541b9e4cdbbc161fb0dd9b228
+LINUX_KERNEL_HASH-5.4.111 = 21626132658dc34cb41b7aa7b80ecf83751890a71ac1a63d77aea9d488271a03
 LINUX_KERNEL_HASH-5.10.31 = 54eef1a4d29a2582281375e028ac73c2c5d90dfa21500fa8c3b00e529a2b510d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 96e124b21a84b3611bb9a284634119737ec9bb00..a207a11ee56f7577ef8f4f091836b0867d8296fc 100644 (file)
@@ -96,7 +96,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -2196,6 +2196,13 @@ config TRIM_UNUSED_KSYMS
+@@ -2195,6 +2195,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
index 1f0c017680993a547b0a8446822d0a0b51d7d51f..c4c13b9695cb121131e851836e4b67910a75e20c 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1278,6 +1278,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
+@@ -1277,6 +1277,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
          the unaligned access emulation.
          see arch/parisc/kernel/unaligned.c for reference
  
index 45eabbd10ab99113a46289b81feacdbbc64b0b45..7523b396bad3b15427a7c3000bb739da5d3d280c 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1663,6 +1663,15 @@ config EMBEDDED
+@@ -1662,6 +1662,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.