ar71xx: build firmware image for the TP-Link TL-WDR4310 v1.0
authorGabor Juhos <juhosg@openwrt.org>
Thu, 12 Jul 2012 13:38:40 +0000 (13:38 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 12 Jul 2012 13:38:40 +0000 (13:38 +0000)
The hardware for TP-Link TL-WDR4300 v1.1 and TL-WDR4310 v1.0 is
identical, but requires different firmware headers:

TL-WDR4300:
00000040  43 00 00 01 00 00 00 01  00 00 00 00 76 fb 83 40  |C...........v..@|

TL-WDR4310:
00000040  43 10 00 01 00 00 00 01  00 00 00 00 38 2b 50 6c  |C...........8+Pl|

[juhosg: change commit message, use a different model name]

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
SVN-Revision: 32683

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 702fa7e5461633fbf89704af02ebe608ee7cc2c3..8c83356ce11f4da40381111711995cff829ef6df 100755 (executable)
@@ -126,6 +126,9 @@ tplink_board_detect() {
        "430000"*)
                model="TP-Link TL-WDR4300"
                ;;
+       "431000"*)
+               model="TP-Link TL-WDR4310"
+               ;;
        *)
                hwver=""
                ;;
index 23e6b96e2e540c295c899fe2f453b19b22fa85db..74355e83b8ecbd898035dbe54458332baa959c2f 100644 (file)
@@ -95,7 +95,7 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR4300
+       NAME:=TP-LINK TL-WDR4300/ TL-WDR4310
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
index 6e2180ea8e85f69f024af1e1efe93db1b67f0360..6c2581ddb511ac2537731286e8276a45bd156c59 100644 (file)
@@ -990,6 +990,7 @@ endef
 tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
 define Image/Build/Profile/TLWDR4300
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
 endef
 
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200