build: add a variable for injecting config variable dependencies for the .prepared...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 14 Jun 2012 20:26:00 +0000 (20:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 14 Jun 2012 20:26:00 +0000 (20:26 +0000)
SVN-Revision: 32368

include/package.mk

index 30dd3ec8286e108de9034a3ce5169a96a9400ace..e955c207aeeae8aaeb62f500d33441113632c8a8 100644 (file)
@@ -31,7 +31,7 @@ ifneq ($(PREV_STAMP_PREPARED),)
   STAMP_PREPARED:=$(PREV_STAMP_PREPARED)
   CONFIG_AUTOREBUILD:=
 else
-  STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
+  STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),))$(call confvar,$(PKG_PREPARED_DEPENDS)))
 endif
 STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
 STAMP_CONFIGURED_WILDCARD=$(patsubst %_$(call confvar,$(PKG_CONFIG_DEPENDS)),%_*,$(STAMP_CONFIGURED))