kernel: remove hack patch, move kirkwood specific kmods to target modules.mk
authorFelix Fietkau <nbd@nbd.name>
Fri, 30 Sep 2022 09:42:06 +0000 (11:42 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 30 Sep 2022 10:59:19 +0000 (12:59 +0200)
Tweaking the KCONFIG line of kmod-ata-marvell-sata makes the hack patch
unnecessary

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/block.mk
package/kernel/linux/modules/other.mk
target/linux/generic/hack-5.10/252-SATA_PMP.patch [deleted file]
target/linux/generic/hack-5.15/252-SATA_PMP.patch [deleted file]
target/linux/kirkwood/modules.mk [new file with mode: 0644]

index 8affa722963ee9e7d72bd3998a533f7a2ce3274d..f6c9df06989abed5de906debf0843124fd504b3f 100644 (file)
@@ -90,21 +90,6 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
-define KernelPackage/ata-marvell-sata
-  TITLE:=Marvell Serial ATA support
-  KCONFIG:=CONFIG_SATA_MV
-  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
-  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
-  $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-marvell-sata/description
- SATA support for marvell chipsets
-endef
-
-$(eval $(call KernelPackage,ata-marvell-sata))
-
-
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV
index 0ab8c7ad4a36d5989fb889c57aa527aaa80b0d76..f15a08d62ea81617eb72d10ad521602f761473ab 100644 (file)
@@ -419,23 +419,6 @@ endef
 $(eval $(call KernelPackage,mmc))
 
 
-define KernelPackage/mvsdio
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Marvell MMC/SD/SDIO host driver
-  DEPENDS:=+kmod-mmc @TARGET_kirkwood
-  KCONFIG:= CONFIG_MMC_MVSDIO
-  FILES:= \
-       $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
-  AUTOLOAD:=$(call AutoProbe,mvsdio,1)
-endef
-
-define KernelPackage/mvsdio/description
- Kernel support for the Marvell SDIO host driver.
-endef
-
-$(eval $(call KernelPackage,mvsdio))
-
-
 define KernelPackage/sdhci
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Secure Digital Host Controller Interface support
diff --git a/target/linux/generic/hack-5.10/252-SATA_PMP.patch b/target/linux/generic/hack-5.10/252-SATA_PMP.patch
deleted file mode 100644 (file)
index 6502d1d..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 8c817e33be829c7249c2cfd59ff48ad5fac6a31d Mon Sep 17 00:00:00 2001
-From: Sungbo Eo <mans0n@gorani.run>
-Date: Fri, 7 Jul 2017 17:09:21 +0200
-Subject: [PATCH] kconfig: solidify SATA_PMP config
-
-SATA_PMP option in kernel config file disappears for every kernel_oldconfig refresh.
-To prevent this, SATA_HOST is now selected automatically when SATA_PMP is enabled.
-This patch can be dropped if SATA_MV is ever re-added into the config.
----
- drivers/ata/Kconfig | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/drivers/ata/Kconfig
-+++ b/drivers/ata/Kconfig
-@@ -112,7 +112,7 @@ config SATA_ZPODD
- config SATA_PMP
-       bool "SATA Port Multiplier support"
--      depends on SATA_HOST
-+      select SATA_HOST
-       default y
-       help
-         This option adds support for SATA Port Multipliers
diff --git a/target/linux/generic/hack-5.15/252-SATA_PMP.patch b/target/linux/generic/hack-5.15/252-SATA_PMP.patch
deleted file mode 100644 (file)
index 6502d1d..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 8c817e33be829c7249c2cfd59ff48ad5fac6a31d Mon Sep 17 00:00:00 2001
-From: Sungbo Eo <mans0n@gorani.run>
-Date: Fri, 7 Jul 2017 17:09:21 +0200
-Subject: [PATCH] kconfig: solidify SATA_PMP config
-
-SATA_PMP option in kernel config file disappears for every kernel_oldconfig refresh.
-To prevent this, SATA_HOST is now selected automatically when SATA_PMP is enabled.
-This patch can be dropped if SATA_MV is ever re-added into the config.
----
- drivers/ata/Kconfig | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/drivers/ata/Kconfig
-+++ b/drivers/ata/Kconfig
-@@ -112,7 +112,7 @@ config SATA_ZPODD
- config SATA_PMP
-       bool "SATA Port Multiplier support"
--      depends on SATA_HOST
-+      select SATA_HOST
-       default y
-       help
-         This option adds support for SATA Port Multipliers
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644 (file)
index 0000000..1543098
--- /dev/null
@@ -0,0 +1,30 @@
+define KernelPackage/ata-marvell-sata
+  TITLE:=Marvell Serial ATA support
+  DEPENDS:=@TARGET_kirkwood
+  KCONFIG:=CONFIG_SATA_MV CONFIG_SATA_PMP=y
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-marvell-sata/description
+ SATA support for marvell chipsets
+endef
+
+$(eval $(call KernelPackage,ata-marvell-sata))
+
+define KernelPackage/mvsdio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell MMC/SD/SDIO host driver
+  DEPENDS:=+kmod-mmc @TARGET_kirkwood
+  KCONFIG:= CONFIG_MMC_MVSDIO
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+  AUTOLOAD:=$(call AutoProbe,mvsdio,1)
+endef
+
+define KernelPackage/mvsdio/description
+ Kernel support for the Marvell SDIO host driver.
+endef
+
+$(eval $(call KernelPackage,mvsdio))