layerscape: add layerscape's SATA driver package
authorPawel Dembicki <paweldembicki@gmail.com>
Tue, 25 Aug 2020 13:26:05 +0000 (15:26 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 2 Oct 2020 15:08:28 +0000 (17:08 +0200)
This patch intruduce SATA support for layerscape devices.
Target specific package with ahci_qoriq driver was added
to local modules.mk.
Kmod package was added to default packages for devices with
SATA interface.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Reviewed-by: Yangbo Lu <yangbo.lu@nxp.com>
package/kernel/linux/modules/block.mk
target/linux/layerscape/image/armv8_64b.mk
target/linux/layerscape/modules.mk

index 8a7232d8be727150aee52f64caafcac1dabed397..373c9fbaaba5454df25613d1ee6f6a4bdc40cf77 100644 (file)
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
     $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
     $(LINUX_DIR)/drivers/ata/libahci_platform.ko
   AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
-  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_sunxi)
+  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_sunxi)
 endef
 
 define KernelPackage/ata-ahci-platform/description
index 5dd7ca955a0fafaea9ed37ba463f17667e64b706..6ed3e7c15570046b2389027697e0a8cd966bc4b7 100644 (file)
@@ -103,6 +103,7 @@ define Device/fsl_ls1043a-rdb
     layerscape-fman \
     tfa-ls1043a-rdb \
     fmc fmc-eth-config \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
@@ -126,6 +127,7 @@ define Device/fsl_ls1043a-rdb-sdboot
     layerscape-fman \
     tfa-ls1043a-rdb-sdboot \
     fmc fmc-eth-config \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
@@ -157,6 +159,7 @@ define Device/fsl_ls1046a-rdb
     layerscape-fman \
     tfa-ls1046a-rdb \
     fmc fmc-eth-config \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
@@ -180,6 +183,7 @@ define Device/fsl_ls1046a-rdb-sdboot
     layerscape-fman \
     tfa-ls1046a-rdb-sdboot \
     fmc fmc-eth-config \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
@@ -212,6 +216,7 @@ define Device/fsl_ls1088a-rdb
     layerscape-dpl \
     tfa-ls1088a-rdb \
     restool \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   IMAGE/firmware.bin := \
@@ -237,6 +242,7 @@ define Device/fsl_ls1088a-rdb-sdboot
     layerscape-dpl \
     tfa-ls1088a-rdb-sdboot \
     restool \
+    kmod-ahci-qoriq \
     kmod-hwmon-ina2xx \
     kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1088a-rdb
@@ -269,7 +275,8 @@ define Device/fsl_ls2088a-rdb
     layerscape-mc \
     layerscape-dpl \
     tfa-ls2088a-rdb \
-    restool
+    restool \
+    kmod-ahci-qoriq
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
index 5f2d472c95d61a4d05bc8eafd2edc91d6d5b5a3d..4d713b597e8d7b0801b256dbe78fb4ba17c13c21 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/ahci-qoriq
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Freescale QorIQ AHCI SATA support
+  KCONFIG:=CONFIG_AHCI_QORIQ
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci_qoriq.ko
+  AUTOLOAD:=$(call AutoLoad,40,ahci-qoriq,1)
+  $(call AddDepends/ata,+kmod-ata-ahci-platform @TARGET_layerscape)
+endef
+
+define KernelPackage/ahci-qoriq/description
+ This option enables support for the Freescale QorIQ AHCI SoC's
+ onboard AHCI SATA.
+endef
+
+$(eval $(call KernelPackage,ahci-qoriq))
+
 define KernelPackage/ppfe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Freescale PPFE Driver support