kernel: bump 4.4 to 4.4.103 for 17.01
authorEtienne Haarsma <bladeoner112@gmail.com>
Fri, 1 Dec 2017 17:26:40 +0000 (18:26 +0100)
committerJohn Crispin <john@phrozen.org>
Tue, 12 Dec 2017 10:10:47 +0000 (11:10 +0100)
Refreshed all patches.

Removed upstream ramips patches:
0101-MIPS-ralink-Fix-MT7628-pinmux.patch
0102--MIPS-ralink-Fix-typo-in-mt7628-pinmux-function.patch

Compile-tested: ar71xx
Run-tested: ar71xx

Signed-off-by: Etienne Haarsma <bladeoner112@gmail.com>
12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/432-spi-rb4xx-spi-driver.patch
target/linux/ar71xx/patches-4.4/433-spi-rb4xx-cpld-driver.patch
target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch
target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
target/linux/generic/patches-4.4/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-4.4/904-debloat_dma_buf.patch
target/linux/lantiq/patches-4.4/0100-spi-add-support-for-Lantiq-SPI-controller.patch
target/linux/ramips/patches-4.4/0042-SPI-ralink-add-Ralink-SoC-spi-driver.patch
target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch
target/linux/ramips/patches-4.4/0101-MIPS-ralink-Fix-MT7628-pinmux.patch [deleted file]
target/linux/ramips/patches-4.4/0102--MIPS-ralink-Fix-typo-in-mt7628-pinmux-function [deleted file]

index b36b6394abf4cedc2cddada5573e01cb2503a036..e90a3c70abd04ed8215381a9ad32318e44e5d7d6 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .102
+LINUX_VERSION-4.4 = .103
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.102 = ede2c22a559e1d894161d53e1d634ee969380a159642aafc0c9c268daf8eaafe
+LINUX_KERNEL_HASH-4.4.103 = 1d01d0785fdf52b3f3b9f7ad05b6cff6be034869935962478e19f265b022f904
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 7d99c43b95d2124d940617b6154576cc9feb7109..d6b71be46a6eea3168c1f1fcbd2df8431f3b2883 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -477,6 +477,12 @@ config SPI_QUP
+@@ -478,6 +478,12 @@ config SPI_QUP
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
index 0932c729f9edebcdd0ba55ab5b249ad882b02fe4..61c186ce9eb1635af0fadd457c0b5a2a73d83d20 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -713,6 +713,13 @@ config SPI_TLE62X0
+@@ -714,6 +714,13 @@ config SPI_TLE62X0
          sysfs interface, with each line presented as a kind of GPIO
          exposing both switch control and diagnostic feedback.
  
          sysfs interface, with each line presented as a kind of GPIO
          exposing both switch control and diagnostic feedback.
  
index 880c088c5699aae0a6d4b4efbdc31817090325c6..94dd1d45081494a9ce6ca6437f7cebec0a0b0c6a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -720,6 +720,11 @@ config SPI_RB4XX_CPLD
+@@ -721,6 +721,11 @@ config SPI_RB4XX_CPLD
          SPI driver for the Xilinx CPLD chip present on the
          MikroTik RB4xx boards.
  
          SPI driver for the Xilinx CPLD chip present on the
          MikroTik RB4xx boards.
  
index c1f565a30795f4a9712b1f189f413dbf06ec0277..b5306a7dbe09afddac15298a47e872a973abcc1a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/probe.c
 +++ b/drivers/pci/probe.c
 --- a/drivers/pci/probe.c
 +++ b/drivers/pci/probe.c
-@@ -1967,7 +1967,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -1978,7 +1978,8 @@ static void pcie_write_mrrs(struct pci_d
        /* In the "safe" case, do not configure the MRRS.  There appear to be
         * issues with setting MRRS to 0 on a number of devices.
         */
        /* In the "safe" case, do not configure the MRRS.  There appear to be
         * issues with setting MRRS to 0 on a number of devices.
         */
index c5f3e195daf30456fce15d339e261266b7b18b7c..4bf34c128e87898c5b5bb87ed446751d8805381f 100644 (file)
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3597,6 +3636,17 @@ static int __net_init ip6_route_net_init
+@@ -3601,6 +3640,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -3615,6 +3665,8 @@ out:
+@@ -3619,6 +3669,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3632,6 +3684,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3636,6 +3688,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3705,6 +3758,9 @@ void __init ip6_route_init_special_entri
+@@ -3709,6 +3762,9 @@ void __init ip6_route_init_special_entri
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 10613de85296f297a99104d91da8258df2a84f65..eac39669d0ab87ea626e1e58a75b4ea784a09145 100644 (file)
@@ -34,7 +34,7 @@
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -2097,6 +2097,7 @@ int wake_up_state(struct task_struct *p,
+@@ -2096,6 +2096,7 @@ int wake_up_state(struct task_struct *p,
  {
        return try_to_wake_up(p, state, 0);
  }
  {
        return try_to_wake_up(p, state, 0);
  }
index 3dc60a70321ac55fc9eabc18f0a59fed09e0022a..daec87c433747f412d7dde5802feef8c8feafa00 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -355,6 +355,13 @@ config SPI_MT65XX
+@@ -356,6 +356,13 @@ config SPI_MT65XX
          say Y or M here.If you are not sure, say N.
          SPI drivers for Mediatek MT65XX and MT81XX series ARM SoCs.
  
          say Y or M here.If you are not sure, say N.
          SPI drivers for Mediatek MT65XX and MT81XX series ARM SoCs.
  
index 642632628b19f14102a05aa9012c6f947b532a07..f79f2cfc5fc2d1309acebfeca7628cc8a9ba2955 100644 (file)
@@ -16,7 +16,7 @@ Acked-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -477,6 +477,12 @@ config SPI_QUP
+@@ -478,6 +478,12 @@ config SPI_QUP
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
index 8a78bda84032bc88ce592782add08c5708d66069..13936b2e1f0baf6f018823f441c02084dcb90b66 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -483,6 +483,12 @@ config SPI_RT2880
+@@ -484,6 +484,12 @@ config SPI_RT2880
        help
          This selects a driver for the Ralink RT288x/RT305x SPI Controller.
  
        help
          This selects a driver for the Ralink RT288x/RT305x SPI Controller.
  
diff --git a/target/linux/ramips/patches-4.4/0101-MIPS-ralink-Fix-MT7628-pinmux.patch b/target/linux/ramips/patches-4.4/0101-MIPS-ralink-Fix-MT7628-pinmux.patch
deleted file mode 100644 (file)
index f2d1ab1..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 8ef4b43cd3794d63052d85898e42424fd3b14d24 Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Thu, 11 May 2017 08:11:14 +0200
-Subject: [PATCH 1/2] MIPS: ralink: Fix MT7628 pinmux
-
-According to the datasheet the REFCLK pin is shared with GPIO#37 and
-the PERST pin is shared with GPIO#36.
-
-Fixes: 53263a1c6852 ("MIPS: ralink: add mt7628an support")
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Acked-by: John Crispin <john@phrozen.org>
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: linux-mips@linux-mips.org
-Cc: <stable@vger.kernel.org> # 3.19+
-Patchwork: https://patchwork.linux-mips.org/patch/16046/
-Signed-off-by: James Hogan <jhogan@kernel.org>
----
- arch/mips/ralink/mt7620.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -141,8 +141,8 @@ static struct rt2880_pmx_func i2c_grp_mt
-       FUNC("i2c", 0, 4, 2),
- };
--static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 36, 1) };
--static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 37, 1) };
-+static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 37, 1) };
-+static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 36, 1) };
- static struct rt2880_pmx_func wdt_grp_mt7628[] = { FUNC("wdt", 0, 38, 1) };
- static struct rt2880_pmx_func spi_grp_mt7628[] = { FUNC("spi", 0, 7, 4) };
diff --git a/target/linux/ramips/patches-4.4/0102--MIPS-ralink-Fix-typo-in-mt7628-pinmux-function b/target/linux/ramips/patches-4.4/0102--MIPS-ralink-Fix-typo-in-mt7628-pinmux-function
deleted file mode 100644 (file)
index 9c77840..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 05a67cc258e75ac9758e6f13d26337b8be51162a Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Thu, 11 May 2017 08:11:15 +0200
-Subject: [PATCH 2/2] MIPS: ralink: Fix typo in mt7628 pinmux function
-
-There is a typo inside the pinmux setup code. The function is called
-refclk and not reclk.
-
-Fixes: 53263a1c6852 ("MIPS: ralink: add mt7628an support")
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Acked-by: John Crispin <john@phrozen.org>
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: linux-mips@linux-mips.org
-Cc: <stable@vger.kernel.org> # 3.19+
-Patchwork: https://patchwork.linux-mips.org/patch/16047/
-Signed-off-by: James Hogan <jhogan@kernel.org>
----
- arch/mips/ralink/mt7620.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -141,7 +141,7 @@ static struct rt2880_pmx_func i2c_grp_mt
-       FUNC("i2c", 0, 4, 2),
- };
--static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 37, 1) };
-+static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("refclk", 0, 37, 1) };
- static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 36, 1) };
- static struct rt2880_pmx_func wdt_grp_mt7628[] = { FUNC("wdt", 0, 38, 1) };
- static struct rt2880_pmx_func spi_grp_mt7628[] = { FUNC("spi", 0, 7, 4) };