malta: relocate CPU_TYPE setting to subtarget makefiles
authorTony Ambardar <itugrok@yahoo.com>
Sun, 16 Aug 2020 20:07:30 +0000 (13:07 -0700)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 27 Oct 2020 20:01:13 +0000 (21:01 +0100)
Move CPU_TYPE:=24kc (32-bit) from the top-level target makefile to the
be/le subtarget makefiles, which is consistent with the 64-bit subtargets.

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
target/linux/malta/Makefile
target/linux/malta/be/target.mk
target/linux/malta/le/target.mk

index 3f2c92c766ad11d6a38571664aa6127eaf105049..4beeb64b8b9aecf82de45f1b9c15217fdb47a4c0 100644 (file)
@@ -8,7 +8,6 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-CPU_TYPE:=24kc
 SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 FEATURES:=cpiogz ext4 ramdisk squashfs targz
index 45949f50c8b9755205088aa74f3fcc12f48c8b17..8d306c8a15705926485b51574714fb2253f03b2a 100644 (file)
@@ -1,4 +1,5 @@
 ARCH:=mips
+CPU_TYPE:=24kc
 SUBTARGET:=be
 BOARDNAME:=Big Endian
 
index e642510621225932f7b713e1ac448209d035bdb7..feb0f1d04c782cd9ca5aafd913e1bc1dc3c132ba 100644 (file)
@@ -1,4 +1,5 @@
 ARCH:=mipsel
+CPU_TYPE:=24kc
 SUBTARGET:=le
 FEATURES+=source-only
 BOARDNAME:=Little Endian