kernel: bump 5.4 to 5.4.135
authorJohn Audia <graysky@archlinux.us>
Sun, 25 Jul 2021 18:36:53 +0000 (14:36 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 31 Jul 2021 17:13:00 +0000 (19:13 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
28 files changed:
include/kernel-version.mk
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.4/950-0208-bcmgenet-Better-coalescing-parameter-defaults.patch
target/linux/bcm27xx/patches-5.4/950-0336-drm-v3d-The-third-IRQ-is-optional.patch
target/linux/bcm27xx/patches-5.4/950-0973-net-bcmgenet-Reset-RBUF-on-first-open.patch
target/linux/gemini/patches-5.4/0003-ARM-dts-gemini-Rename-IDE-nodes.patch
target/linux/generic/backport-5.4/747-v5.5-net-dsa-mv88e6xxx-Add-support-for-port-mirroring.patch
target/linux/generic/backport-5.4/748-v5.5-net-dsa-mv88e6xxx-fix-broken-if-statement-because-of.patch
target/linux/generic/pending-5.4/768-net-dsa-mv88e6xxx-Request-assisted-learning-on-CPU-port.patch
target/linux/layerscape/patches-5.4/302-dts-0010-arm64-dts-ls208xa-accumulated-change-to-ls208xa-boar.patch
target/linux/layerscape/patches-5.4/302-dts-0025-arm64-dts-nxp-ls208xa-add-more-thermal-zone-support.patch
target/linux/layerscape/patches-5.4/302-dts-0032-arm64-dts-Added-endianness-information-to-dts-serdes.patch
target/linux/layerscape/patches-5.4/302-dts-0045-arm64-dts-Fix-DWC3-IP-VBUS-glitch-issue-on-Layerscap.patch
target/linux/layerscape/patches-5.4/302-dts-0051-arm64-dts-fsl-layerscape-fix-warnings-when-compiling.patch
target/linux/layerscape/patches-5.4/302-dts-0063-arm64-dts-fsl-remove-backplane-support.patch
target/linux/layerscape/patches-5.4/302-dts-0070-arm64-dts-ls1012a-ls1043a-ls1046a-ls1088a-ls208xa-re.patch
target/linux/layerscape/patches-5.4/302-dts-0078-arm64-dts-fix-endianness-of-rcpm.patch
target/linux/layerscape/patches-5.4/302-dts-0097-LF-387-5-arm64-dts-layerscape-add-chip-specific-comp.patch
target/linux/layerscape/patches-5.4/302-dts-0099-arm64-dts-layerscape-apply-dma-coherent-for-dwc3-nod.patch
target/linux/layerscape/patches-5.4/302-dts-0100-arm64-dts-ls208xa-Update-qspi-node-properties-for-LS.patch
target/linux/layerscape/patches-5.4/302-dts-0101-arm64-dts-ls208xa-Remove-dma-coherent-from-dwc3-node.patch
target/linux/layerscape/patches-5.4/701-net-0273-net-dsa-ocelot-add-tsn-support-for-felix-switch.patch
target/linux/mediatek/patches-5.4/0310-mtk-bmt-support.patch
target/linux/mediatek/patches-5.4/1011-net-ethernet-mtk_eth_soc-add-support-for-coherent-DM.patch
target/linux/mvebu/patches-5.4/020-arm64-dts-marvell-armada-37xx-Set-pcie_reset_pin-to-.patch
target/linux/mvebu/patches-5.4/021-arm64-dts-marvell-armada-37xx-Move-PCIe-comphy-handl.patch
target/linux/mvebu/patches-5.4/022-arm64-dts-marvell-armada-37xx-Move-PCIe-max-link-spe.patch
target/linux/ramips/patches-5.4/401-net-ethernet-mediatek-support-net-labels.patch

index b70dc5b89ded67c0904effdccb05572176db3c3c..0ec155de2d5767a8dac6c4fd0236a1a28b90d3d3 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .134
+LINUX_VERSION-5.4 = .135
 LINUX_VERSION-5.10 = .54
 
-LINUX_KERNEL_HASH-5.4.134 = c9fb861642161c256e10c97c35ccce18831e688d87ead53c18e3226778e05841
+LINUX_KERNEL_HASH-5.4.135 = 83efa4c8c725bd2a5e66e2db5612d0ee586449d36661d13889b9ddf0203efdf1
 LINUX_KERNEL_HASH-5.10.54 = bf50c63261847187eca4a1793e5df5c1355b21697409589f6ca03e32b629be44
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 99520863d3e1e82e2539c5687a058979675eb0e5..55b198eb0c3e00d1f452449d0ed72882959532aa 100644 (file)
  #include <linux/uaccess.h>
  #include <linux/ipv6.h>
  #include <linux/icmpv6.h>
-@@ -849,10 +850,10 @@ static void tcp_v6_send_response(const s
+@@ -864,10 +865,10 @@ static void tcp_v6_send_response(const s
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
index 3a38f64436f7748d60f5173b2f177c725b29f06b..1d3765b93c9649ce333864768f773db36d3e343d 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Disable rate control for now */
        bcmgenet_tdma_ring_writel(priv, index, flow_period_val,
                                  TDMA_FLOW_PERIOD);
-@@ -3573,9 +3573,12 @@ static int bcmgenet_probe(struct platfor
+@@ -3579,9 +3579,12 @@ static int bcmgenet_probe(struct platfor
        netif_set_real_num_rx_queues(priv->dev, priv->hw_params->rx_queues + 1);
  
        /* Set default coalescing parameters */
index 97ff76a6a33b65ed9ad2771269254da4ad577698..ab3c053c3f02c5b789e3053cdf8445dd6741445d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -3474,7 +3474,7 @@ static int bcmgenet_probe(struct platfor
+@@ -3480,7 +3480,7 @@ static int bcmgenet_probe(struct platfor
        priv = netdev_priv(dev);
        priv->irq0 = platform_get_irq(pdev, 0);
        priv->irq1 = platform_get_irq(pdev, 1);
index b7f0ce0cad8d7a95b26aa20bd8de1906961a2e88..60505cf4ed0cdf386c4e72a3293fa013c993ad9a 100644 (file)
@@ -31,9 +31,9 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 -static u32 bcmgenet_dma_disable(struct bcmgenet_priv *priv)
 +static u32 bcmgenet_dma_disable(struct bcmgenet_priv *priv, bool flush_rx)
  {
+       unsigned int i;
        u32 reg;
-       u32 dma_ctrl;
-@@ -2809,6 +2809,14 @@ static u32 bcmgenet_dma_disable(struct b
+@@ -2815,6 +2815,14 @@ static u32 bcmgenet_dma_disable(struct b
        udelay(10);
        bcmgenet_umac_writel(priv, 0, UMAC_TX_FLUSH);
  
@@ -48,7 +48,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        return dma_ctrl;
  }
  
-@@ -2910,8 +2918,8 @@ static int bcmgenet_open(struct net_devi
+@@ -2916,8 +2924,8 @@ static int bcmgenet_open(struct net_devi
                bcmgenet_ext_writel(priv, reg, EXT_EXT_PWR_MGMT);
        }
  
@@ -59,7 +59,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
  
        /* Reinitialize TDMA and RDMA and SW housekeeping */
        ret = bcmgenet_init_dma(priv);
-@@ -3671,7 +3679,7 @@ static int bcmgenet_resume(struct device
+@@ -3677,7 +3685,7 @@ static int bcmgenet_resume(struct device
                bcmgenet_power_up(priv, GENET_POWER_WOL_MAGIC);
  
        /* Disable RX/TX DMA and flush TX queues */
index 6477b2d2a468cacd664c6dc814ea3e8332f74fba..cf4a74f86a793ae95507a7090dadb2abe28a0090 100644 (file)
@@ -84,7 +84,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  
 --- a/arch/arm/boot/dts/gemini.dtsi
 +++ b/arch/arm/boot/dts/gemini.dtsi
-@@ -356,7 +356,7 @@
+@@ -357,7 +357,7 @@
                        };
                };
  
@@ -93,7 +93,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
                        compatible = "cortina,gemini-pata", "faraday,ftide010";
                        reg = <0x63000000 0x1000>;
                        interrupts = <4 IRQ_TYPE_EDGE_RISING>;
-@@ -365,9 +365,11 @@
+@@ -366,9 +366,11 @@
                        clock-names = "PCLK";
                        sata = <&sata>;
                        status = "disabled";
@@ -106,7 +106,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
                        compatible = "cortina,gemini-pata", "faraday,ftide010";
                        reg = <0x63400000 0x1000>;
                        interrupts = <5 IRQ_TYPE_EDGE_RISING>;
-@@ -376,6 +378,8 @@
+@@ -377,6 +379,8 @@
                        clock-names = "PCLK";
                        sata = <&sata>;
                        status = "disabled";
index 30ff8aeab60f270838c5ffdd311d7f2747219d55..a23f45075f82158bff0cf7315ac5878aee3ce12b 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -4922,6 +4922,80 @@ static int mv88e6xxx_port_mdb_del(struct
+@@ -4926,6 +4926,80 @@ static int mv88e6xxx_port_mdb_del(struct
        return err;
  }
  
@@ -106,7 +106,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int mv88e6xxx_port_egress_floods(struct dsa_switch *ds, int port,
                                         bool unicast, bool multicast)
  {
-@@ -4976,6 +5050,8 @@ static const struct dsa_switch_ops mv88e
+@@ -4980,6 +5054,8 @@ static const struct dsa_switch_ops mv88e
        .port_mdb_prepare       = mv88e6xxx_port_mdb_prepare,
        .port_mdb_add           = mv88e6xxx_port_mdb_add,
        .port_mdb_del           = mv88e6xxx_port_mdb_del,
index d8ec1240f7e07feb92055c036eecc3df822ed6a9..37e7a7f2a9ceec73724ce9d349750d39e7d8ea09 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -4989,7 +4989,7 @@ static void mv88e6xxx_port_mirror_del(st
+@@ -4993,7 +4993,7 @@ static void mv88e6xxx_port_mirror_del(st
                if (chip->info->ops->set_egress_port(chip,
                                                     direction,
                                                     dsa_upstream_port(ds,
index 653a782f520f29d04e7a80aa056786fd5df58340..cb421f164bdc121a30be8bfafaf02ed896a306aa 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -5076,6 +5076,7 @@ static int mv88e6xxx_register_switch(str
+@@ -5080,6 +5080,7 @@ static int mv88e6xxx_register_switch(str
        ds->ops = &mv88e6xxx_switch_ops;
        ds->ageing_time_min = chip->info->age_time_coeff;
        ds->ageing_time_max = chip->info->age_time_coeff * U8_MAX;
index 2b1bd825a4a7a383a64269775181f1599d5d6426..a763e057249a3a2e6e252db0c87cfdc2f1753736 100644 (file)
@@ -702,7 +702,7 @@ binding
        };
  
        pmu {
-@@ -560,15 +559,126 @@
+@@ -559,15 +558,126 @@
                        #interrupt-cells = <2>;
                };
  
@@ -831,7 +831,7 @@ binding
                };
  
                i2c1: i2c@2010000 {
-@@ -579,7 +689,7 @@
+@@ -578,7 +688,7 @@
                        reg = <0x0 0x2010000 0x0 0x10000>;
                        interrupts = <0 34 0x4>; /* Level high type */
                        clock-names = "i2c";
@@ -840,7 +840,7 @@ binding
                };
  
                i2c2: i2c@2020000 {
-@@ -590,7 +700,7 @@
+@@ -589,7 +699,7 @@
                        reg = <0x0 0x2020000 0x0 0x10000>;
                        interrupts = <0 35 0x4>; /* Level high type */
                        clock-names = "i2c";
@@ -849,7 +849,7 @@ binding
                };
  
                i2c3: i2c@2030000 {
-@@ -601,7 +711,7 @@
+@@ -600,7 +710,7 @@
                        reg = <0x0 0x2030000 0x0 0x10000>;
                        interrupts = <0 35 0x4>; /* Level high type */
                        clock-names = "i2c";
@@ -858,7 +858,7 @@ binding
                };
  
                ifc: ifc@2240000 {
-@@ -633,8 +743,8 @@
+@@ -632,8 +742,8 @@
                pcie1: pcie@3400000 {
                        compatible = "fsl,ls2080a-pcie", "fsl,ls2085a-pcie";
                        reg-names = "regs", "config";
@@ -869,7 +869,7 @@ binding
                        #address-cells = <3>;
                        #size-cells = <2>;
                        device_type = "pci";
-@@ -642,6 +752,7 @@
+@@ -641,6 +751,7 @@
                        num-viewport = <6>;
                        bus-range = <0x0 0xff>;
                        msi-parent = <&its>;
@@ -877,7 +877,7 @@ binding
                        #interrupt-cells = <1>;
                        interrupt-map-mask = <0 0 0 7>;
                        interrupt-map = <0000 0 0 1 &gic 0 0 0 109 4>,
-@@ -654,8 +765,8 @@
+@@ -653,8 +764,8 @@
                pcie2: pcie@3500000 {
                        compatible = "fsl,ls2080a-pcie", "fsl,ls2085a-pcie";
                        reg-names = "regs", "config";
@@ -888,7 +888,7 @@ binding
                        #address-cells = <3>;
                        #size-cells = <2>;
                        device_type = "pci";
-@@ -663,6 +774,7 @@
+@@ -662,6 +773,7 @@
                        num-viewport = <6>;
                        bus-range = <0x0 0xff>;
                        msi-parent = <&its>;
@@ -896,7 +896,7 @@ binding
                        #interrupt-cells = <1>;
                        interrupt-map-mask = <0 0 0 7>;
                        interrupt-map = <0000 0 0 1 &gic 0 0 0 114 4>,
-@@ -675,8 +787,8 @@
+@@ -674,8 +786,8 @@
                pcie3: pcie@3600000 {
                        compatible = "fsl,ls2080a-pcie", "fsl,ls2085a-pcie";
                        reg-names = "regs", "config";
@@ -907,7 +907,7 @@ binding
                        #address-cells = <3>;
                        #size-cells = <2>;
                        device_type = "pci";
-@@ -684,6 +796,7 @@
+@@ -683,6 +795,7 @@
                        num-viewport = <256>;
                        bus-range = <0x0 0xff>;
                        msi-parent = <&its>;
@@ -915,7 +915,7 @@ binding
                        #interrupt-cells = <1>;
                        interrupt-map-mask = <0 0 0 7>;
                        interrupt-map = <0000 0 0 1 &gic 0 0 0 119 4>,
-@@ -696,8 +809,8 @@
+@@ -695,8 +808,8 @@
                pcie4: pcie@3700000 {
                        compatible = "fsl,ls2080a-pcie", "fsl,ls2085a-pcie";
                        reg-names = "regs", "config";
@@ -926,7 +926,7 @@ binding
                        #address-cells = <3>;
                        #size-cells = <2>;
                        device_type = "pci";
-@@ -705,6 +818,7 @@
+@@ -704,6 +817,7 @@
                        num-viewport = <6>;
                        bus-range = <0x0 0xff>;
                        msi-parent = <&its>;
@@ -934,7 +934,7 @@ binding
                        #interrupt-cells = <1>;
                        interrupt-map-mask = <0 0 0 7>;
                        interrupt-map = <0000 0 0 1 &gic 0 0 0 124 4>,
-@@ -754,11 +868,22 @@
+@@ -753,11 +867,22 @@
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                };
  
index 42deb82ea33b199a3457368e7c652e46b36f4e37..5434e1f913cfb17cf1b7be3d88d1337acd9c8294 100644 (file)
@@ -146,7 +146,7 @@ Signed-off-by: Yuantian Tang <andy.tang@nxp.com>
  
        timer: timer {
                compatible = "arm,armv8-timer";
-@@ -907,3 +872,36 @@
+@@ -906,3 +871,36 @@
                };
        };
  };
index 255250681500ecf830f6948a52f609779d3548c0..b19431d567621f1b2ec4527ad6457d55ef2c764a 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Florinel Iordache <florinel.iordache@nxp.com>
                tmu: tmu@1f80000 {
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -834,8 +834,9 @@
+@@ -833,8 +833,9 @@
                };
  
                serdes1: serdes@1ea0000 {
index c2b7e1fde2c3f25c27ec3e9b3d698b364ec67d6b..10eca4a0832f3e5cf0860b5b86f1aeb714540cc3 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
  
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -820,6 +820,7 @@
+@@ -819,6 +819,7 @@
                        snps,quirk-frame-length-adjustment = <0x20>;
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
@@ -106,7 +106,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
                };
  
                usb1: usb3@3110000 {
-@@ -831,6 +832,7 @@
+@@ -830,6 +831,7 @@
                        snps,quirk-frame-length-adjustment = <0x20>;
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
index d4875bc8771842c8f2ec0748b42a2858546b05d0..7ac2f3166b342de5347a731c1ab3b0d6063936d4 100644 (file)
@@ -117,7 +117,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
   *
   * Abhimanyu Saini <abhimanyu.saini@nxp.com>
   *
-@@ -525,7 +525,7 @@
+@@ -524,7 +524,7 @@
                };
  
                /* TODO: WRIOP (CCSR?) */
@@ -126,7 +126,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                                          * E-MDIO1: 0x1_6000
                                          */
                        compatible = "fsl,fman-memac-mdio";
-@@ -538,7 +538,7 @@
+@@ -537,7 +537,7 @@
                        #size-cells = <0>;
                };
  
@@ -135,7 +135,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                                          * E-MDIO2: 0x1_7000
                                          */
                        compatible = "fsl,fman-memac-mdio";
-@@ -550,7 +550,7 @@
+@@ -549,7 +549,7 @@
                        #size-cells = <0>;
                };
  
@@ -144,7 +144,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c07000 0x0 0x1000>;
                        device_type = "mdio";
-@@ -560,7 +560,7 @@
+@@ -559,7 +559,7 @@
                        #size-cells = <0>;
                };
  
@@ -153,7 +153,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c0b000 0x0 0x1000>;
                        device_type = "mdio";
-@@ -570,7 +570,7 @@
+@@ -569,7 +569,7 @@
                        #size-cells = <0>;
                };
  
@@ -162,7 +162,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c0f000 0x0 0x1000>;
                        device_type = "mdio";
-@@ -580,7 +580,7 @@
+@@ -579,7 +579,7 @@
                        #size-cells = <0>;
                };
  
@@ -171,7 +171,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c13000 0x0 0x1000>;
                        device_type = "mdio";
-@@ -590,7 +590,7 @@
+@@ -589,7 +589,7 @@
                        #size-cells = <0>;
                };
  
@@ -180,7 +180,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        status = "disabled";
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c17000 0x0 0x1000>;
-@@ -601,7 +601,7 @@
+@@ -600,7 +600,7 @@
                        #size-cells = <0>;
                };
  
@@ -189,7 +189,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        status = "disabled";
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c1b000 0x0 0x1000>;
-@@ -612,7 +612,7 @@
+@@ -611,7 +611,7 @@
                        #size-cells = <0>;
                };
  
@@ -198,7 +198,7 @@ Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
                        status = "disabled";
                        compatible = "fsl,fman-memac-mdio";
                        reg = <0x0 0x8c1f000 0x0 0x1000>;
-@@ -623,7 +623,7 @@
+@@ -622,7 +622,7 @@
                        #size-cells = <0>;
                };
  
index d65b222c334bb0f7bda8ba26a7414cd12bc8c6ae..749df043e09239fbbfea71b79747a43320556a3f 100644 (file)
@@ -260,7 +260,7 @@ Signed-off-by: Florinel Iordache <florinel.iordache@nxp.com>
        phy-handle = <&mdio0_phy12>;
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -550,90 +550,6 @@
+@@ -549,90 +549,6 @@
                        #size-cells = <0>;
                };
  
@@ -351,7 +351,7 @@ Signed-off-by: Florinel Iordache <florinel.iordache@nxp.com>
                i2c0: i2c@2000000 {
                        status = "disabled";
                        compatible = "fsl,vf610-i2c", "fsl,ls208xa-vf610-i2c";
-@@ -835,12 +751,6 @@
+@@ -834,12 +750,6 @@
                        snps,host-vbus-glitches;
                };
  
index baa4c79586b37f4a1dea3dab00c1e1a61458bac5..78713d778e1127f422f6ca37c485785406494d39 100644 (file)
@@ -276,7 +276,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        };
  
        cpu: cpus {
-@@ -757,9 +758,16 @@
+@@ -756,9 +757,16 @@
                        interrupts = <0 12 4>;
                };
  
index 53a8a5506abcfe1fea5aaa7dd7bf485082dd8e6d..4aabcebcae34efc5c2a05f1f1b7bf0a7fdc63067 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
                ftm_alarm0: timer@2800000 {
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -762,6 +762,7 @@
+@@ -761,6 +761,7 @@
                        compatible = "fsl,ls208xa-rcpm", "fsl,qoriq-rcpm-2.1+";
                        reg = <0x0 0x1e34040 0x0 0x18>;
                        #fsl,rcpm-wakeup-cells = <6>;
index 333fecb3fd6aae094777ca9513e058da592a2137..25d66a4ba6514a2070a927f0dec55a8b56d59e6c 100644 (file)
@@ -110,7 +110,7 @@ Reviewed-by: Leo Li <leo.li@nxp.com>
                        dr_mode = "host";
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -730,7 +730,7 @@
+@@ -729,7 +729,7 @@
  
                usb0: usb3@3100000 {
                        status = "disabled";
@@ -119,7 +119,7 @@ Reviewed-by: Leo Li <leo.li@nxp.com>
                        reg = <0x0 0x3100000 0x0 0x10000>;
                        interrupts = <0 80 0x4>; /* Level high type */
                        dr_mode = "host";
-@@ -742,7 +742,7 @@
+@@ -741,7 +741,7 @@
  
                usb1: usb3@3110000 {
                        status = "disabled";
index 5d325baabcd0c1454355e2ef9ae9d29ad082f7f3..ef719e393b5b7527463e8ccce7b55fa76cf772cc 100644 (file)
@@ -122,7 +122,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
  
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -738,6 +738,7 @@
+@@ -737,6 +737,7 @@
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                        snps,host-vbus-glitches;
@@ -130,7 +130,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
                };
  
                usb1: usb3@3110000 {
-@@ -750,6 +751,7 @@
+@@ -749,6 +750,7 @@
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                        snps,host-vbus-glitches;
index 0b2de32302f82c6d023741fe336d2ba992dda7ee..6efbe1ecf1a70be5f2d5b7be66d717e468f212f5 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Kuldeep Singh <kuldeep.singh@nxp.com>
  };
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -610,16 +610,16 @@
+@@ -609,16 +609,16 @@
                };
  
                qspi: spi@20c0000 {
index dcd3beeb041cf54d2e447837f5a84320a82dc2bd..dc9017536227059e16cc147313d45f8550517fa4 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
 
 --- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
-@@ -738,7 +738,6 @@
+@@ -737,7 +737,6 @@
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                        snps,host-vbus-glitches;
@@ -26,7 +26,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
                };
  
                usb1: usb3@3110000 {
-@@ -751,7 +750,6 @@
+@@ -750,7 +749,6 @@
                        snps,dis_rxdet_inp3_quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                        snps,host-vbus-glitches;
index 72b101bfb0bc5ae69ad72249593ca238934f1c25..22d6c97a72fd18d7e286b40ba106ba9f08b2f16e 100644 (file)
@@ -658,7 +658,7 @@ Signed-off-by: Xiaoliang Yang <xiaoliang.yang_1@nxp.com>
  struct dsa_switch_driver {
 --- a/net/dsa/dsa2.c
 +++ b/net/dsa/dsa2.c
-@@ -323,6 +323,10 @@ static int dsa_port_setup(struct dsa_por
+@@ -325,6 +325,10 @@ static int dsa_port_setup(struct dsa_por
                if (err)
                        break;
  
index 2a23f8c3dc83688eb934fe3224e3baea03356106..4cef9f9d5ea6d6a14d9c73c37e93d2a3ddfc318a 100644 (file)
  
  static int spinand_read_reg_op(struct spinand_device *spinand, u8 reg, u8 *val)
  {
-@@ -1099,6 +1100,8 @@ static int spinand_probe(struct spi_mem
+@@ -1100,6 +1101,8 @@ static int spinand_probe(struct spi_mem
        if (ret)
                return ret;
  
        ret = mtd_device_register(mtd, NULL, 0);
        if (ret)
                goto err_spinand_cleanup;
-@@ -1124,6 +1127,7 @@ static int spinand_remove(struct spi_mem
+@@ -1125,6 +1128,7 @@ static int spinand_remove(struct spi_mem
        if (ret)
                return ret;
  
index e75d76b9cc67f18043a0ad5d538106c4deb52613..3d62f40544af1be3f702dd3b8b5a93cf8579ce52 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (MTK_HAS_CAPS(eth->soc->caps, MTK_SOC_MT7628)) {
                ret = device_reset(eth->dev);
                if (ret) {
-@@ -3104,6 +3112,16 @@ static int mtk_probe(struct platform_dev
+@@ -3106,6 +3114,16 @@ static int mtk_probe(struct platform_dev
                }
        }
  
index 9eeddaeba1600ec86940f145f1fe377d0a75f43c..cd15b20ed1f8224db827d2622142148b5880aa5e 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
  /* J6 */
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -120,10 +120,6 @@
+@@ -126,10 +126,6 @@
        };
  };
  
index 0c7830cb4750dbff21421f50b56159d01768fb4e..b42192d9fd062ab50d5f22589c76dfa551a581f7 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
        reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -126,7 +126,6 @@
+@@ -132,7 +132,6 @@
        status = "okay";
        max-link-speed = <2>;
        reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
index 04002480cc5a07d75b1548e1008e972d9993edbd..43cda3f29f7f90c64de8edfb90ec7cae756d35d9 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -124,7 +124,6 @@
+@@ -130,7 +130,6 @@
        pinctrl-names = "default";
        pinctrl-0 = <&pcie_reset_pins &pcie_clkreq_pins>;
        status = "okay";
index b011b140c7666ceb49c44a9781a15f257fe4d7a4..f29156340b1d149a69a6003659b3e5836b4b2fa2 100644 (file)
@@ -22,9 +22,9 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
        const __be32 *_id = of_get_property(np, "reg", NULL);
        struct phylink *phylink;
        int phy_mode, id, err;
-@@ -3035,6 +3036,9 @@ static int mtk_add_mac(struct mtk_eth *e
-       eth->netdev[id]->max_mtu = MTK_MAX_RX_LENGTH - MTK_RX_ETH_HLEN;
+@@ -3037,6 +3038,9 @@ static int mtk_add_mac(struct mtk_eth *e
+       
+       of_platform_device_create(np, NULL, NULL);
  
 +      if (name)
 +              strlcpy(eth->netdev[id]->name, name, IFNAMSIZ);