bcm27xx: add isp-bcm2835 kernel module
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sat, 27 Jan 2024 23:05:35 +0000 (00:05 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 5 Feb 2024 17:25:16 +0000 (18:25 +0100)
kmod-isp-bcm2835 enables ISP HW on the Raspberry Pi.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm27xx/modules/video.mk

index 5846616f83e1c87e6d167297cd45f45eda44fdf9..c9b9555b04a2cd76a93073b6739b6ea5eef1ad31 100644 (file)
@@ -65,6 +65,24 @@ endef
 $(eval $(call KernelPackage,drm-vc4))
 
 
+define KernelPackage/isp-bcm2835
+  TITLE:=BCM2835 ISP
+  KCONFIG:= \
+    CONFIG_VIDEO_ISP_BCM2835
+  FILES:= \
+    $(LINUX_DIR)/drivers/staging/vc04_services/bcm2835-isp/bcm2835-isp.ko
+  AUTOLOAD:=$(call AutoLoad,67,bcm2835-isp)
+  $(call AddDepends/video,@TARGET_bcm27xx +kmod-vchiq-mmal-bcm2835 +kmod-video-dma)
+endef
+
+define KernelPackage/isp-bcm2835/description
+  V4L2 driver for the Broadcom BCM2835 ISP hardware.
+  This operates over the VCHIQ interface to a service running on VideoCore.
+endef
+
+$(eval $(call KernelPackage,isp-bcm2835))
+
+
 define KernelPackage/vc-sm-cma
   TITLE:=VideoCore Shared Memory (CMA) driver
   KCONFIG:= \