gemini: Cook SQ201 images
authorLinus Walleij <linus.walleij@linaro.org>
Fri, 15 Jun 2018 21:34:57 +0000 (23:34 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 04:35:33 +0000 (06:35 +0200)
This generates the "rd.gz" and "hddapp.tgz" that doesn't contain
anything of the sort but rather the OpenWRT rootfs. It works the
same way as how we generate the same layout for the NAS4220b.
For some reason the ImageInfo file is different for the SQ201.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/gemini/image/ImageInfo-sq201 [new file with mode: 0644]
target/linux/gemini/image/Makefile

diff --git a/target/linux/gemini/image/ImageInfo-sq201 b/target/linux/gemini/image/ImageInfo-sq201
new file mode 100644 (file)
index 0000000..86040ab
--- /dev/null
@@ -0,0 +1,18 @@
+UpgradeImages="zImage rd.gz hddapp.tgz"
+Procduction="SL3516"
+BOOT_VER="1.0.5"
+FIRMWARE_VER="firmware-openwrt-DATESTR"
+INTERNAL_FIRMWARE_VER="firmware-openwrt-DATESTR"
+CONFIGURATION_VER="firmware-openwrt"
+DESCRIPTION="Square One Router/Nas"
+TSS="enabled"
+DIRECT_MODE="disabled"
+DEFAULT_LAN_IPADDR="192.168.1.1"
+DEFAULT_LAN_NETMASK="255.255.255.0"
+DEFAULT_LAN_BOOTPROTO="none"
+DEFAULT_WAN_BOOTPROTO="dhcp"
+DEFAULT_WAN_ENABLED="yes"
+DEFAULT_WLAN_DEVICENAME="eth0"
+VER_zImage="DATESTR"
+VER_Ramdisk="DATESTR"
+VER_hddapp="DATESTR"
index ba2ee02bfa7df8857088d09c6557e8712a25299f..a05b7111b5bcd25c8ed7cd6c7f585358ddeeda35 100644 (file)
@@ -54,6 +54,21 @@ define Build/nas4220b-images
        rm -f $(BIN_DIR)/ImageInfo
 endef
 
+# The Itian Square One SQ201 uses the same method.
+define Build/sq201-images
+       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
+       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
+       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
+       cp ./ImageInfo-sq201 $(BIN_DIR)/ImageInfo
+       sed -i -e "s/DATESTR/`date +%Y%m%d`/g" $(BIN_DIR)/ImageInfo
+       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-sq201.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
+       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-sq201-rd.gz
+       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-sq201-hddapp.tgz
+       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-sq201-zImage
+       rm -f $(BIN_DIR)/ImageInfo
+endef
+
+
 # WBD-111 and WBD-222:
 # work around the bootloader's bug with extra nops
 # FIXME: is this really needed now that we no longer append the code
@@ -120,6 +135,8 @@ TARGET_DEVICES += rut1xx
 
 define Device/sq201
        DEVICE_TITLE := ITian Square One SQ201
+       IMAGES += sq201-image
+       IMAGE/sq201-image := sq201-images
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci
 endef
 TARGET_DEVICES += sq201