ath79: Add support for Plasma Cloud PA300E
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 18:11:50 +0000 (19:11 +0100)
Device specifications:

* Qualcomm/Atheros QCA9533 v2
* 650/600/217 MHz (CPU/DDR/AHB)
* 64 MB of RAM
* 16 MB of SPI NOR flash (mx25l12805d)
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2x 10/100 Mbps Ethernet
* 2T2R 2.4 GHz Wi-Fi
* multi-color LED (controlled via red/green/blue GPIOs)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x fast ethernet
  - eth0
    + Label: Ethernet 1
    + 24V passive POE (mode B)
    + used as WAN interface
  - eth1
    + Label: Ethernet 2
    + 802.3af POE
    + builtin switch port 2
    + used as LAN interface
* 12-24V 1A DC
* external antennas

Flashing instructions:

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the factory image to the u-boot when the device boots up.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 40fbc96a0770918b62b99c99ac45d1dce7e93132..496a27ceb258addd5ec0cec348ba32cbc1fe3934 100644 (file)
@@ -81,7 +81,8 @@ netgear,wndr4300tn|\
 netgear,wndr4300sw)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x20000"
        ;;
-plasmacloud,pa300)
+plasmacloud,pa300|\
+plasmacloud,pa300e)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x40000"
        ;;
 qihoo,c301)
diff --git a/target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts b/target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts
new file mode 100644 (file)
index 0000000..1527a79
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9533_plasmacloud_pa300.dtsi"
+
+/ {
+       compatible = "plasmacloud,pa300e", "qca,qca9533";
+       model = "Plasma Cloud PA300E";
+};
index f868d8dc94a8938c0077116adebe8a59254a5450..ac1fc4406d024e90d04bfa1fc0c5b70464e321da 100755 (executable)
@@ -150,6 +150,7 @@ ath79_setup_interfaces()
        comfast,cf-e314n-v2|\
        compex,wpj531-16m|\
        plasmacloud,pa300|\
+       plasmacloud,pa300e|\
        tplink,cpe210-v1|\
        tplink,cpe220-v2|\
        tplink,cpe220-v3|\
index 68733ccf154582e29b6416ad8daa7eb7a81bcc7e..002f5f9668978292615b19c3ba14b17afac709e2 100644 (file)
@@ -45,7 +45,8 @@ platform_do_upgrade_dualboot_datachk() {
        # boot anymore to Linux until it was reflashed with ap51-flash.
        local next_boot_part="1"
        case "$(board_name)" in
-       plasmacloud,pa300)
+       plasmacloud,pa300|\
+       plasmacloud,pa300e)
                primary_kernel_mtd=3
                ;;
        *)
index 3ce273990f6bc3d91548bd7a92a08f8baaa010ed..98861685dc2d7060fd8225b22ff2e0e9478051fc 100644 (file)
@@ -50,7 +50,8 @@ platform_do_upgrade() {
        jjplus,ja76pf2)
                redboot_fis_do_upgrade "$1" linux
                ;;
-       plasmacloud,pa300)
+       plasmacloud,pa300|\
+       plasmacloud,pa300e)
                PART_NAME="inactive"
                platform_do_upgrade_dualboot_datachk "$1"
                ;;
index 935dee75d7b06598424554c37cf8f56b899281a2..037d572d974ee3acbe39abfeb0c13594ed8212b5 100644 (file)
@@ -1597,6 +1597,12 @@ define Device/plasmacloud_pa300
 endef
 TARGET_DEVICES += plasmacloud_pa300
 
+define Device/plasmacloud_pa300e
+  $(Device/plasmacloud_pa300-common)
+  DEVICE_MODEL := PA300E
+endef
+TARGET_DEVICES += plasmacloud_pa300e
+
 define Device/qihoo_c301
   $(Device/seama)
   SOC := ar9344