malta: move 32-bits options to subtarget config
authorFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:36:45 +0000 (12:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:36:45 +0000 (12:36 +0000)
Preliminary change to add support for MIPS64-based malta subtargets.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 36210

target/linux/malta/Makefile
target/linux/malta/be/config-default
target/linux/malta/be/target.mk
target/linux/malta/le/config-default
target/linux/malta/le/target.mk

index 9b342c8f5c0b0f410e598a8f29698ff1601c0761..eb3c8d3d46a4b318713536c1900cc64565689bfd 100644 (file)
@@ -8,7 +8,6 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
index ccc0ba4eb14094845f6fcb987f1895b7ed322b04..ed67d802aeac6354ac3133d248dc0bbbae960d02 100644 (file)
@@ -1,2 +1,10 @@
+CONFIG_32BIT=y
+# CONFIG_64BIT is not set
 CONFIG_CPU_BIG_ENDIAN=y
 # CONFIG_CPU_LITTLE_ENDIAN is not set
+CONFIG_CPU_MIPS32=y
+# CONFIG_CPU_MIPS32_R1 is not set
+CONFIG_CPU_MIPS32_R2=y
+# CONFIG_CPU_MIPS64_R1 is not set
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
index 92ae58eb9d301462d4a3b374e9abbe9aa6cfe611..90b655c8d2d2b043031098eb71f5303800341254 100644 (file)
@@ -3,6 +3,7 @@ ARCH_PACKAGES:=malta_mips
 SUBTARGET:=be
 BOARDNAME:=Big Endian
 FEATURES:=ramdisk mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 define Target/Description
        Build BE firmware images for MIPS Malta CoreLV board running in
index 396e1b75f9b0b0957b86ac67170ff264fdb23c4d..368eca098a6de79bcfa71f4f39a1d726fedde930 100644 (file)
@@ -1,2 +1,10 @@
+CONFIG_32BIT=y
+# CONFIG_64BIT is not set
 # CONFIG_CPU_BIG_ENDIAN is not set
 CONFIG_CPU_LITTLE_ENDIAN=y
+CONFIG_CPU_MIPS32=y
+# CONFIG_CPU_MIPS32_R1 is not set
+CONFIG_CPU_MIPS32_R2=y
+# CONFIG_CPU_MIPS64_R1 is not set
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
index 35fcf4cfe1f87a3fb088efeee44c25d8d64e0cff..3b6e8953d014799552122f80796a4715ebe1ab61 100644 (file)
@@ -3,6 +3,7 @@ ARCH_PACKAGES:=malta_mipsel
 SUBTARGET:=le
 BOARDNAME:=Little Endian
 FEATURES:=ramdisk mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 define Target/Description
        Build LE firmware images for MIPS Malta CoreLV board running in