build: unsilence move command
authorThomas Reifferscheid <thomas@reifferscheid.org>
Mon, 20 Feb 2017 16:48:50 +0000 (17:48 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 13:31:36 +0000 (14:31 +0100)
The @ sign in front of the "mv" command was significantly suppressing
output to stdout. When reviewing the make/build logs it was tricking
me a whole lot and it mad me lose time. Removing the @ sign will get
stdout and logs right about what happened when.

Signed-off-by: Thomas Reifferscheid <thomas@reifferscheid.org>
(cherry picked from commit 1d49b534f5b74676f30f2ee1ba78d9e02d59f0bc)

include/image-commands.mk

index 04fa853fbbd99936c547d5eb0862137cba22809d..ec35e0fcfe97d9d98c731459d1f1681d2bcfe5ad 100644 (file)
@@ -8,7 +8,7 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
 endef
 
 define Build/netgear-chk