ar71xx: build image for the Buffalo WHR-G301N
authorGabor Juhos <juhosg@openwrt.org>
Mon, 7 Nov 2011 12:59:08 +0000 (12:59 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 7 Nov 2011 12:59:08 +0000 (12:59 +0000)
SVN-Revision: 28804

target/linux/ar71xx/generic/profiles/buffalo.mk
target/linux/ar71xx/image/Makefile

index 411dec69b287a252e6538b391578ee2b1cd784c4..a6de0af2bef456fd3a572cc1c3fe3feb23825e56 100644 (file)
@@ -27,6 +27,18 @@ endef
 
 $(eval $(call Profile,WZRHPAG300H))
 
+define Profile/WHRG301N
+       NAME:=Buffalo WHR-G301N
+       PACKAGES:=
+endef
+
+define Profile/WHRG301N/Description
+       Package set optimized for the Buffalo WHR-G301N.
+endef
+
+$(eval $(call Profile,WHRG301N))
+
+
 define Profile/WHRHPG300N
        NAME:=Buffalo WHR-HP-G300N
        PACKAGES:=
index 48289a5de115956c0c8e8f055e46cba128c7747e..c070eac3609d6ddc33100dd841dfac6db9905ac2 100644 (file)
@@ -707,6 +707,11 @@ define Image/Build/Profile/WRT160NL
        $(call Image/Build/Template/$(fs_64k)/$(1),CyberTAN,wrt160nl,$(wrt160nl_cmdline),1.00.01)
 endef
 
+whrg301n_cmdline=board=WHR-G301N console=ttyS0,115200
+define Image/Build/Profile/WHRG301N
+       $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-g301n,$(whrg301n_cmdline),whrhpg300n_mtdlayout,WHR-G301N)
+endef
+
 whrhpg300n_cmdline=board=WHR-HP-G300N console=ttyS0,115200
 whrhpg300n_mtdlayout=mtdparts=spi0.0:248k(u-boot)ro,8k(u-boot-env)ro,896k(kernel),2816k(rootfs),64k(user_property),64k(art)ro,3712k@0x30000(firmware)
 define Image/Build/Profile/WHRHPG300N
@@ -785,6 +790,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/AP96,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))
        $(call Image/Build/Profile/WRT160NL,$(1))
+       $(call Image/Build/Profile/WHRG301N,$(1))
        $(call Image/Build/Profile/WHRHPG300N,$(1))
        $(call Image/Build/Profile/WZRHPG300NH,$(1))
        $(call Image/Build/Profile/WZRHPAG300H,$(1))