bcm27xx: bcm2712: remove boot-2711 image files
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 1 Feb 2024 10:54:22 +0000 (11:54 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 1 Feb 2024 11:05:08 +0000 (12:05 +0100)
According to Raspberry Pi documentation, the RPi 5 First Stage Bootloader
loads the linux kernel instead of loading the Second Stage Bootloader
(start.elf):
https://www.raspberrypi.com/documentation/computers/raspberry-pi.html#differences-on-raspberry-pi-5

Fixes: 8b63d9a ("bcm27xx: add new bcm2712 subtarget")
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm27xx/image/Makefile

index e5c2d154994a32f7de080f789e5f4f78426dd704..12ac0012a49169415d71a8bcc8944826322beadb 100644 (file)
@@ -182,8 +182,8 @@ define Device/rpi-5
        brcmfmac-nvram-43455-sdio \
        kmod-brcmfmac wpad-basic-mbedtls \
        kmod-hwmon-pwmfan kmod-thermal
-  IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
-  IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
+  IMAGE/sysupgrade.img.gz := boot-common | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-common | sdcard-img | gzip
 endef
 ifeq ($(SUBTARGET),bcm2712)
   TARGET_DEVICES += rpi-5