ar71xx: fix oprofile support
authorFelix Fietkau <nbd@openwrt.org>
Thu, 11 Mar 2010 18:48:57 +0000 (18:48 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 11 Mar 2010 18:48:57 +0000 (18:48 +0000)
SVN-Revision: 20150

target/linux/ar71xx/files/arch/mips/ar71xx/irq.c
target/linux/ar71xx/patches-2.6.33/300-mips_fw_myloader.patch
target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.34/208-mips_oprofile_fix.patch [new file with mode: 0644]

index 13d25c43fd30fd024802df6cb77c5b7d606ef760..3a91e00aad69d7ccd4a17a2dd0b2be09a335e70a 100644 (file)
@@ -405,6 +405,8 @@ void __init arch_init_irq(void)
 
        ar71xx_misc_irq_init();
 
+       cp0_perfcount_irq = AR71XX_MISC_IRQ_PERFC;
+
        switch (ar71xx_soc) {
        case AR71XX_SOC_AR7130:
        case AR71XX_SOC_AR7141:
index 0d8f132dd00c36faae6bce11ed8b555451d055b2..48d0de83aaee767baa9d065c30a7fe6ec0f2aafd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -188,6 +188,7 @@ endif
+@@ -190,6 +190,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
diff --git a/target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch
new file mode 100644 (file)
index 0000000..2e019db
--- /dev/null
@@ -0,0 +1,47 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -48,7 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
+   endif
+ endif
++ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
++endif
+ cflags-y += $(call cc-option, -mno-check-zero-division)
+ ifdef CONFIG_32BIT
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+       }
+ }
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++      return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+       int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+       save_perf_irq = perf_irq;
+       perf_irq = mipsxx_perfcount_handler;
++      if (cp0_perfcount_irq >= 0)
++              return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++                      IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+       return 0;
+ }
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+       int counters = op_model_mipsxx_ops.num_counters;
++      if (cp0_perfcount_irq >= 0)
++              free_irq(cp0_perfcount_irq, save_perf_irq);
++
+       counters = counters_per_cpu_to_total(counters);
+       on_each_cpu(reset_counters, (void *)(long)counters, 1);
diff --git a/target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch
new file mode 100644 (file)
index 0000000..0cbf4ed
--- /dev/null
@@ -0,0 +1,48 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
+ endif
+ ifndef CONFIG_FUNCTION_TRACER
+-cflags-y := -ffunction-sections
++  ifndef CONFIG_PROFILING
++    cflags-y := -ffunction-sections
++  endif
+ endif
+ ifdef CONFIG_FUNCTION_GRAPH_TRACER
+   ifndef KBUILD_MCOUNT_RA_ADDRESS
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+       }
+ }
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++      return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+       int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+       save_perf_irq = perf_irq;
+       perf_irq = mipsxx_perfcount_handler;
++      if (cp0_perfcount_irq >= 0)
++              return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++                      IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+       return 0;
+ }
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+       int counters = op_model_mipsxx_ops.num_counters;
++      if (cp0_perfcount_irq >= 0)
++              free_irq(cp0_perfcount_irq, save_perf_irq);
++
+       counters = counters_per_cpu_to_total(counters);
+       on_each_cpu(reset_counters, (void *)(long)counters, 1);
diff --git a/target/linux/generic-2.6/patches-2.6.34/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.34/208-mips_oprofile_fix.patch
new file mode 100644 (file)
index 0000000..0cbf4ed
--- /dev/null
@@ -0,0 +1,48 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
+ endif
+ ifndef CONFIG_FUNCTION_TRACER
+-cflags-y := -ffunction-sections
++  ifndef CONFIG_PROFILING
++    cflags-y := -ffunction-sections
++  endif
+ endif
+ ifdef CONFIG_FUNCTION_GRAPH_TRACER
+   ifndef KBUILD_MCOUNT_RA_ADDRESS
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+       }
+ }
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++      return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+       int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+       save_perf_irq = perf_irq;
+       perf_irq = mipsxx_perfcount_handler;
++      if (cp0_perfcount_irq >= 0)
++              return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++                      IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+       return 0;
+ }
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+       int counters = op_model_mipsxx_ops.num_counters;
++      if (cp0_perfcount_irq >= 0)
++              free_irq(cp0_perfcount_irq, save_perf_irq);
++
+       counters = counters_per_cpu_to_total(counters);
+       on_each_cpu(reset_counters, (void *)(long)counters, 1);