bmips: add wifi packages for supported devices
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 23 Mar 2021 19:23:47 +0000 (20:23 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 23 Mar 2021 19:23:47 +0000 (20:23 +0100)
Netgear DGND3700v2 / Comtrend VR-3032u internal wireless not supported.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bmips/image/Makefile
target/linux/bmips/image/bcm63xx_generic.mk
target/linux/bmips/image/bcm63xx_nand.mk

index c1534a88db6627ef85e71d913f7af182da00f982..89cd04b0ec710f0d62eda342344423ab010f9505 100644 (file)
@@ -249,6 +249,8 @@ define Device/Default
   DEVICE_LOADADDR :=
 endef
 
+ATH9K_PACKAGES := kmod-ath9k wpad-basic-wolfssl
+B43_PACKAGES := kmod-b43 wpad-basic-wolfssl
 USB1_PACKAGES := kmod-usb-ohci kmod-ledtrig-usbdev
 USB2_PACKAGES := $(USB1_PACKAGES) kmod-usb2
 
index 6f9a7b9a49bbf6fd6d3de8394f8f670a2abc9bc4..33282bd1a50136c9ece6d88d837a2b2ea4f11b1e 100644 (file)
@@ -33,7 +33,7 @@ define Device/comtrend_ar-5315u
   CHIP_ID := 6318
   CFE_BOARD_ID := 96318A-1441N1
   FLASH_MB := 16
-  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES)
 endef
 TARGET_DEVICES += comtrend_ar-5315u
 
@@ -44,7 +44,7 @@ define Device/comtrend_ar-5387un
   CHIP_ID := 6328
   CFE_BOARD_ID := 96328A-1441N1
   FLASH_MB := 16
-  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES)
 endef
 TARGET_DEVICES += comtrend_ar-5387un
 
@@ -56,7 +56,7 @@ define Device/comtrend_vr-3025u
   CFE_BOARD_ID := 96368M-1541N
   BLOCKSIZE := 0x20000
   FLASH_MB := 32
-  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES)
 endef
 TARGET_DEVICES += comtrend_vr-3025u
 
@@ -69,6 +69,6 @@ define Device/huawei_hg556a-b
   CFE_BOARD_ID := HW556
   CFE_EXTRAS += --rsa-signature "EchoLife_HG556a" --tag-version 8
   BLOCKSIZE := 0x20000
-  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  DEVICE_PACKAGES += $(USB2_PACKAGES) $(ATH9K_PACKAGES)
 endef
 TARGET_DEVICES += huawei_hg556a-b
index a712cd06999f3a2a300c7cae8e9e8b4c1b7e61e2..82b04891d5e4c72b4bca8d9a952805623e799844 100644 (file)
@@ -74,7 +74,7 @@ define Device/netgear_dgnd3700-v2
   CFE_RAM_JFFS2_PAD := 496k
   BLOCKSIZE := 16k
   PAGESIZE := 512
-  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES)
   CFE_WFI_FLASH_TYPE := 2
   CFE_WFI_VERSION := 0x5731
 endef