mvebu: 6.6: refresh patches
[openwrt/openwrt.git] / target / linux / mvebu / patches-6.6 / 902-drivers-mfd-Add-a-driver-for-IEI-WT61P803-PUZZLE-MCU.patch
index 47d9e3a263761b02676579e40a0bfebf931c5d69..1046b15e4b79dc215b83b2a836942bd6e5287b56 100644 (file)
@@ -26,7 +26,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/mfd/Kconfig
 +++ b/drivers/mfd/Kconfig
-@@ -2222,6 +2222,15 @@ config SGI_MFD_IOC3
+@@ -2274,6 +2274,15 @@ config SGI_MFD_IOC3
          If you have an SGI Origin, Octane, or a PCI IOC3 card,
          then say Y. Otherwise say N.
  
@@ -39,9 +39,9 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 +        used for fan control, temperature sensor reading, LED control
 +        and system identification.
 +
- config MFD_INTEL_M10_BMC
-       tristate "Intel MAX 10 Board Management Controller"
-       depends on SPI_MASTER
+ config MFD_INTEL_M10_BMC_CORE
+         tristate
+         select MFD_CORE
 --- a/drivers/mfd/Makefile
 +++ b/drivers/mfd/Makefile
 @@ -244,6 +244,7 @@ obj-$(CONFIG_MFD_RT4831)   += rt4831.o