brcm2708: add support for Raspberry Pi 2B 1.2
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index 01d1bf585f3f4089db11529654c23df3ed729cfd..db2b3b55621844e2643ec8841b473f3cc8d48f2c 100644 (file)
@@ -72,7 +72,10 @@ endef
 
 define Device/rpi
   DEVICE_MODEL := B/B+/CM/Zero/ZeroW
-  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-zero bcm2708-rpi-zero-w
+  DEVICE_DTS := \
+       bcm2708-rpi-b bcm2708-rpi-b-plus \
+       bcm2708-rpi-cm \
+       bcm2708-rpi-zero bcm2708-rpi-zero-w
   SUPPORTED_DEVICES := \
        rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w \
        raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,model-b-rev2 \
@@ -89,10 +92,14 @@ endif
 
 define Device/rpi-2
   DEVICE_MODEL := 2B/3B/3B+/3CM/4B
-  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2711-rpi-4-b bcm2710-rpi-cm3
+  DEVICE_DTS := \
+       bcm2709-rpi-2-b bcm2710-rpi-2-b \
+       bcm2710-rpi-3-b bcm2710-rpi-3-b-plus \
+       bcm2711-rpi-4-b \
+       bcm2710-rpi-cm3
   SUPPORTED_DEVICES := \
        rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
-       raspberrypi,2-model-b \
+       raspberrypi,2-model-b raspberrypi,2-model-b-rev2 \
        raspberrypi,3-model-b raspberrypi,3-model-b-plus \
        raspberrypi,3-compute-module raspberrypi,compute-module-3 \
        raspberrypi,4-model-b
@@ -110,11 +117,15 @@ ifeq ($(SUBTARGET),bcm2709)
 endif
 
 define Device/rpi-3
-  DEVICE_MODEL := 3B/3B+/3CM
+  DEVICE_MODEL := 2B-1.2/3B/3B+/3CM
   KERNEL_IMG := kernel8.img
-  DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus broadcom/bcm2710-rpi-cm3
+  DEVICE_DTS := \
+       broadcom/bcm2710-rpi-2-b \
+       broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus \
+       broadcom/bcm2710-rpi-cm3
   SUPPORTED_DEVICES := \
        rpi-3-b rpi-3-b-plus \
+       raspberrypi,2-model-b-rev2 \
        raspberrypi,3-model-b raspberrypi,3-model-b-plus \
        raspberrypi,3-compute-module raspberrypi,compute-module-3
   DEVICE_PACKAGES := \