kernel: kmod-ata-ahci-platform: enable support for RK35xx
[openwrt/staging/stintel.git] / package / kernel / linux / modules / block.mk
index 8affa722963ee9e7d72bd3998a533f7a2ce3274d..4f3a6e085ffb2296d3806fa7bb42a1b909a3ed4c 100644 (file)
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
     $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
     $(LINUX_DIR)/drivers/ata/libahci_platform.ko
   AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
-  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_sunxi)
+  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_rockchip||TARGET_sunxi)
 endef
 
 define KernelPackage/ata-ahci-platform/description
@@ -90,21 +90,6 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
-define KernelPackage/ata-marvell-sata
-  TITLE:=Marvell Serial ATA support
-  KCONFIG:=CONFIG_SATA_MV
-  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
-  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
-  $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-marvell-sata/description
- SATA support for marvell chipsets
-endef
-
-$(eval $(call KernelPackage,ata-marvell-sata))
-
-
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV
@@ -278,7 +263,7 @@ define KernelPackage/iscsi-initiator
        CONFIG_INET \
        CONFIG_SCSI_LOWLEVEL=y \
        CONFIG_ISCSI_TCP \
-       CONFIG_SCSI_ISCSI_ATTRS=y
+       CONFIG_SCSI_ISCSI_ATTRS
   FILES:= \
        $(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
        $(LINUX_DIR)/drivers/scsi/libiscsi.ko \
@@ -511,16 +496,16 @@ $(eval $(call KernelPackage,nbd))
 define KernelPackage/nvme
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=NVM Express block device
-  DEPENDS:=@PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
   KCONFIG:= \
        CONFIG_NVME_CORE \
        CONFIG_BLK_DEV_NVME \
        CONFIG_NVME_MULTIPATH=n \
-       CONFIG_NVME_HWMON=n
+       CONFIG_NVME_HWMON=y
   FILES:= \
        $(LINUX_DIR)/drivers/nvme/host/nvme-core.ko \
        $(LINUX_DIR)/drivers/nvme/host/nvme.ko
-  AUTOLOAD:=$(call AutoLoad,30,nvme-core nvme)
+  AUTOLOAD:=$(call AutoLoad,30,nvme-core nvme,1)
 endef
 
 define KernelPackage/nvme/description
@@ -536,13 +521,13 @@ define KernelPackage/scsi-core
   TITLE:=SCSI device support
   KCONFIG:= \
        CONFIG_SCSI \
-       CONFIG_SCSI_COMMON@ge5.15 \
+       CONFIG_SCSI_COMMON \
        CONFIG_BLK_DEV_SD
   FILES:= \
        $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
-       $(LINUX_DIR)/drivers/scsi/scsi_common.ko@ge5.15 \
+       $(LINUX_DIR)/drivers/scsi/scsi_common.ko \
        $(LINUX_DIR)/drivers/scsi/sd_mod.ko
-  AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common@ge5.15 sd_mod,1)
+  AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common sd_mod,1)
 endef
 
 $(eval $(call KernelPackage,scsi-core))