etk: fix compile, add missing dependency
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 May 2009 11:22:40 +0000 (11:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 May 2009 11:22:40 +0000 (11:22 +0000)
SVN-Revision: 16176

efl/etk/Makefile

index ab5613d2debc37cc3678d0567fb4e690e6e00a18..3daa37f2452f927fa6e4a1247a8558707837a19f 100644 (file)
@@ -22,6 +22,8 @@ PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
 
 PKG_FIXUP = libtool
 
+PKG_BUILD_DEPENDS:=edje/host
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/etk
@@ -30,7 +32,7 @@ define Package/etk
   SUBMENU:=libraries
   TITLE:=Etk is a toolkit based on the EFL
   URL:=http://wiki.enlightenment.org/index.php/Etk
-  DEPENDS:=+evas +ecore +edje
+  DEPENDS:=+evas +ecore +edje +libintl
 endef
 
 define Package/etk/description
@@ -50,9 +52,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       ln -sf `which edje_cc` $(STAGING_DIR_HOST)/usr/bin/
        DESTDIR="$(PKG_INSTALL_DIR)" $(MAKE) -C $(PKG_BUILD_DIR) all install
-       rm -f $(STAGING_DIR_HOST)/usr/bin/edje_cc
 endef
 
 define Build/InstallDev