hostapd: fix broke noscan option for mesh
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 8 Nov 2023 15:46:12 +0000 (16:46 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 9 Nov 2023 15:18:58 +0000 (16:18 +0100)
noscan option for mesh was broken and actually never applied.

This is caused by a typo where ssid->noscan value is check instead of
conf->noscan resulting in the logic swapped and broken.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit 1b5ea2e199fcf391f88afd0322de449459399be4)
[ rework for openwrt-22.03 ]

package/network/services/hostapd/Makefile
package/network/services/hostapd/patches/301-mesh-noscan.patch

index a06f6a0523e243ae295a4772ffae93e15776cb66..f831304dcdc1e74df41e3f5cbee225662bf8b9b1 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=$(AUTORELEASE).2
+PKG_RELEASE:=$(AUTORELEASE).3
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index e682efb543ee3055f862f46a3782c56fa8298cf4..b27ffc44937e194bd020a47e52f39dc2c251d7a7 100644 (file)
@@ -24,8 +24,8 @@
                           frequency);
                goto out_free;
        }
-+      if (ssid->noscan)
-+              conf->noscan = 1;
++      if (conf->noscan)
++              ssid->noscan = 1;
  
        if (ssid->mesh_basic_rates == NULL) {
                /*