kernel: netsupport: Add kmod-sched-skbprio
authorAlexandru Gagniuc <mr.nuke.me@gmail.com>
Thu, 27 Jul 2023 15:51:33 +0000 (10:51 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 11 Aug 2023 10:53:34 +0000 (12:53 +0200)
Add support for the SKBPRIO queuing discipline. This is subtly
different than prio as it also drops packets from the lower priority
flows.

Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com>
(cherry picked from commit 8fba9afda5f514afa48a216514b3f0b0fb22afac)

package/kernel/linux/modules/netsupport.mk

index 1d5950d237e9d82004853202755d2bd3f8c8f64d..97556e459db8998ae921a04856622e8e52009404 100644 (file)
@@ -971,6 +971,18 @@ endef
 $(eval $(call KernelPackage,sched-red))
 
 
+define KernelPackage/sched-skbprio
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=SKB priority queue scheduler (SKBPRIO)
+  DEPENDS:=+kmod-sched-core
+  KCONFIG:= CONFIG_NET_SCH_SKBPRIO
+  FILES:= $(LINUX_DIR)/net/sched/sch_skbprio.ko
+  AUTOLOAD:=$(call AutoProbe,sch_skbprio)
+endef
+
+$(eval $(call KernelPackage,sched-skbprio))
+
+
 define KernelPackage/bpf-test
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Test Berkeley Packet Filter functionality