build: fix pkg-config detection when inside of a nix-shell
authorSandro Jäckel <sandro.jaeckel@gmail.com>
Wed, 1 Nov 2023 15:49:20 +0000 (16:49 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 2 Nov 2023 21:40:40 +0000 (22:40 +0100)
The output of command_all when inside a nix-shell looks like the below
where /usr does not match:

 ➜ scripts/command_all.sh pkg-config
/nix/store/ifr6srqgpvygd5vp14748d109ri31isv-pkg-config-wrapper-0.29.2/bin/pkg-config

Signed-off-by: Sandro Jäckel <sandro.jaeckel@gmail.com>
(cherry picked from commit 86ca7199dfb132042ce3110acef23d74f4ef14a7)

Makefile

index c325034bb9da4f8b1d1e90af7183df75a1d1c2d0..9bdb03a443ff857497c1961937b4812aa57d3890 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
 
 world:
 
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -e '/usr' -e '/nix/store' -m 1)
 
 export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
 export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH)