ramips: use full 8MB flash on ZyXEL Keenetic
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
Wed, 8 Apr 2020 18:43:36 +0000 (21:43 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 12 Apr 2020 11:48:31 +0000 (13:48 +0200)
ZyXEL Keenetic has 8MB flash, but OpenWrt uses only 4MB.
This commit fixes the problem.

WikiDevi page [1] says that ZyXEL Keenetic has FLA1: 8 MiB, there is
an article with specs [2] (in Russian).

[1] https://wikidevi.wi-cat.ru/ZyXEL_Keenetic
[2] https://3dnews.ru/608774/page-2.html

Fixes: FS#2487
Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn")
Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
(cherry picked from commit fea232ae8feb6af780fd4fa78ebe9231778bf75a)

target/linux/ramips/dts/kn.dts
target/linux/ramips/image/rt305x.mk

index 77b047c094c0546ee0cbb3461c61cd2d7db81e97..94f6cddf94101e2c26dfec5062e820e11f5f7db9 100644 (file)
@@ -37,7 +37,7 @@
 
                partition@50000 {
                        label = "firmware";
-                       reg = <0x50000 0x3b0000>;
+                       reg = <0x50000 0x7b0000>;
                };
        };
 
index 2d071c1ebc6dc19d51f6d5786dffbca5d8b7e90d..062319705518782cfb5b60c48178f7b5b454eb32 100644 (file)
@@ -895,7 +895,7 @@ TARGET_DEVICES += xdxrn502j
 define Device/kn
   DTS := kn
   BLOCKSIZE := 64k
-  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  IMAGE_SIZE := 7872k
   DEVICE_TITLE := ZyXEL Keenetic
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
 endef