keepalived: add patch to remove log message on json output
authorFlorian Eckert <fe@dev.tdt.de>
Tue, 16 Apr 2024 07:11:11 +0000 (09:11 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 8 May 2024 09:04:37 +0000 (11:04 +0200)
The 'luci-app-keepalived' uses the status json output to parse this
information for the status page. The problem is that when the LuCI
status page is open in the browser, the query is logged every 3 second into
the syslog. This is not needed and can therefore be removed.

This patch was already merged upstream:
https://github.com/acassen/keepalived/commit/6cce75f4eb65551a61d2e4ba775637b288c1d592

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/keepalived/Makefile
net/keepalived/patches/0001-vrrp-remove-logging-on-status-output.patch [new file with mode: 0644]

index b04e45e9355e0bfd640019304461921c5ac922d7..f020e11f8255abb8718f72f29e7f86d49e71bf35 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
 PKG_VERSION:=2.2.8
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.keepalived.org/software
diff --git a/net/keepalived/patches/0001-vrrp-remove-logging-on-status-output.patch b/net/keepalived/patches/0001-vrrp-remove-logging-on-status-output.patch
new file mode 100644 (file)
index 0000000..1988a0b
--- /dev/null
@@ -0,0 +1,24 @@
+From 6cce75f4eb65551a61d2e4ba775637b288c1d592 Mon Sep 17 00:00:00 2001
+From: Florian Eckert <fe@dev.tdt.de>
+Date: Mon, 6 May 2024 13:10:55 +0200
+Subject: [PATCH] vrrp: remove logging on status output
+
+A message is output to the log each time the status is queried. This is
+not necessary and can therefore be omitted.
+
+Signed-off-by: Florian Eckert <fe@dev.tdt.de>
+---
+ keepalived/vrrp/vrrp_daemon.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+--- a/keepalived/vrrp/vrrp_daemon.c
++++ b/keepalived/vrrp/vrrp_daemon.c
+@@ -755,8 +755,6 @@ sigusr2_vrrp(__attribute__((unused)) voi
+ static void
+ sigjson_vrrp(__attribute__((unused)) void *v, __attribute__((unused)) int sig)
+ {
+-      log_message(LOG_INFO, "Printing VRRP as json for process(%d) on signal",
+-              getpid());
+       thread_add_event(master, print_vrrp_json, NULL, 0);
+ }
+ #endif