rootfs: fix USE_APK detection main master
authorPaul Spooren <mail@aparcar.org>
Sat, 18 May 2024 20:10:49 +0000 (23:10 +0300)
committerPaul Spooren <mail@aparcar.org>
Sat, 18 May 2024 20:15:22 +0000 (23:15 +0300)
Due to missing quotes the script would wrongly assume APK to be enabled
and don't run post install scripts, breaking pretty much everything.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/rootfs.mk

index eb4fa434a365101f63970db7057e2d4487ad81f0..907a95a794a34af71e86a4c6eb9c4b1ec6109e33 100644 (file)
@@ -78,7 +78,7 @@ define prepare_rootfs
        @mkdir -p $(1)/var/lock
        @( \
                cd $(1); \
-               if [ -n $(CONFIG_USE_APK) ]; then \
+               if [ -n "$(CONFIG_USE_APK)" ]; then \
                $(STAGING_DIR_HOST)/bin/tar -xf ./lib/apk/db/scripts.tar --wildcards "*.post-install" -O > script.sh; \
                chmod +x script.sh; \
                IPKG_INSTROOT=$(1) $$(command -v bash) script.sh; \