only override the uci conf dir in dummy mode
authorFelix Fietkau <nbd@openwrt.org>
Sun, 2 Oct 2011 16:38:58 +0000 (18:38 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 2 Oct 2011 16:38:58 +0000 (18:38 +0200)
CMakeLists.txt
config.c

index de0c74b35829721d99d6bb6c10c420b9b07f29ef..8fb8ae15a5baf90ab00ccd5d41fcf070aa919998 100644 (file)
@@ -22,6 +22,7 @@ IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} nl)
 ELSE()
+       ADD_DEFINITIONS(-DDUMMY_MODE=1)
        SET(SOURCES ${SOURCES} system-dummy.c)
 ENDIF()
 
index 81cbd28180f42c817c139c2044d5425612ec7dcc..8705c16accaa799dcd32e91bc3734838df89e2d5 100644 (file)
--- a/config.c
+++ b/config.c
@@ -215,7 +215,9 @@ config_init_interfaces(const char *name)
        ctx = uci_alloc_context();
        uci_ctx = ctx;
 
+#ifdef DUMMY_MODE
        uci_set_confdir(ctx, "./config");
+#endif
 
        if (uci_load(ctx, "network", &p)) {
                fprintf(stderr, "Failed to load network config\n");