imx: imx8m: not build bootaux when building SPL
authorPeng Fan <peng.fan@nxp.com>
Tue, 20 Nov 2018 10:19:50 +0000 (10:19 +0000)
committerStefano Babic <sbabic@denx.de>
Tue, 1 Jan 2019 13:12:18 +0000 (14:12 +0100)
No need to build bootaux in SPL stage

Signed-off-by: Peng Fan <peng.fan@nxp.com>
arch/arm/mach-imx/Makefile

index 6351abb18518d5ed87c62554cc7a3bbd588b069f..d236e4051083d67ff34646e38f660fc3ed2aa3b7 100644 (file)
@@ -10,7 +10,9 @@ obj-y = iomux-v3.o
 endif
 
 ifeq ($(SOC),$(filter $(SOC),imx8m))
+ifneq ($(CONFIG_SPL_BUILD),y)
 obj-$(CONFIG_IMX_BOOTAUX) += imx_bootaux.o
+endif
 obj-$(CONFIG_ENV_IS_IN_MMC) += mmc_env.o
 obj-$(CONFIG_FEC_MXC) += mac.o
 obj-$(CONFIG_SYS_I2C_MXC) += i2c-mxv7.o