gpio: introduce CONFIG_SPL_DM_PCA953X
authorPeng Fan <peng.fan@nxp.com>
Fri, 21 Dec 2018 06:21:21 +0000 (06:21 +0000)
committerStefano Babic <sbabic@denx.de>
Mon, 28 Jan 2019 19:35:47 +0000 (20:35 +0100)
Introduce CONFIG_SPL_DM_PCA953X for SPL usage.

Signed-off-by: Peng Fan <peng.fan@nxp.com>
drivers/gpio/Kconfig
drivers/gpio/Makefile

index 14a14be91773be1ca1d3172c33cd9ccb447cabe9..b103180cf3778f103575d7a7d740525993070a78 100644 (file)
@@ -303,6 +303,29 @@ config DM_PCA953X
          Now, max 24 bits chips and PCA953X compatible chips are
          supported
 
+config SPL_DM_PCA953X
+       bool "PCA95[357]x, PCA9698, TCA64xx, and MAX7310 I/O ports in SPL"
+       depends on DM_GPIO
+       help
+         Say yes here to provide access to several register-oriented
+         SMBus I/O expanders, made mostly by NXP or TI.  Compatible
+         models include:
+
+         4 bits:       pca9536, pca9537
+
+         8 bits:       max7310, max7315, pca6107, pca9534, pca9538, pca9554,
+                       pca9556, pca9557, pca9574, tca6408, xra1202
+
+         16 bits:      max7312, max7313, pca9535, pca9539, pca9555, pca9575,
+                       tca6416
+
+         24 bits:      tca6424
+
+         40 bits:      pca9505, pca9698
+
+         Now, max 24 bits chips and PCA953X compatible chips are
+         supported
+
 config MPC8XXX_GPIO
        bool "Freescale MPC8XXX GPIO driver"
        depends on DM_GPIO
index 7c479efe2d641a222d718ed8996e5e032d5d0e95..3be325044f9b84e74f98d733055a9ac3b4211b2b 100644 (file)
@@ -9,7 +9,7 @@ obj-$(CONFIG_AXP_GPIO)          += axp_gpio.o
 endif
 obj-$(CONFIG_DM_GPIO)          += gpio-uclass.o
 
-obj-$(CONFIG_DM_PCA953X)       += pca953x_gpio.o
+obj-$(CONFIG_$(SPL_)DM_PCA953X)        += pca953x_gpio.o
 obj-$(CONFIG_DM_74X164)                += 74x164_gpio.o
 
 obj-$(CONFIG_AT91_GPIO)        += at91_gpio.o