Fix Makefile for ARMv8-A AArch32 build
authorSandrine Bailleux <sandrine.bailleux@arm.com>
Fri, 24 Nov 2017 08:43:40 +0000 (08:43 +0000)
committerSandrine Bailleux <sandrine.bailleux@arm.com>
Fri, 24 Nov 2017 08:46:57 +0000 (08:46 +0000)
Commit 26e63c4450 broke the Makefile for ARMv8-A AArch32 platforms.
This patch fixes it.

Change-Id: I49b8eb5b88f3a131aa4c8642ef970e92d90b6dd2
Signed-off-by: Sandrine Bailleux <sandrine.bailleux@arm.com>
Makefile

index d186e8b152b730ee7d2e67c21ef95728ac8b43fc..31ef7699c2bd8b5b12b948027ad5f5a668d25c0e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -131,7 +131,7 @@ target32-directive  =       -target arm-none-eabi
 # Will set march32-directive from platform configuration
 else
 target32-directive     =       -target armv8a-none-eabi
-march32-directive      =       -march armv8-a
+march32-directive      =       -march=armv8-a
 endif
 
 ifeq ($(notdir $(CC)),armclang)