Select SCMI/SDS drivers by default on Juno
authorSandrine Bailleux <sandrine.bailleux@arm.com>
Wed, 28 Feb 2018 10:47:23 +0000 (11:47 +0100)
committerSandrine Bailleux <sandrine.bailleux@arm.com>
Wed, 28 Feb 2018 12:08:08 +0000 (13:08 +0100)
The SCP binaries provided in the 17.10 Linaro release (and onwards)
have migrated to the SCMI/SDS protocols. Therefore, the ARM TF should
now use the corresponding drivers by default.

This patch changes the default value of the CSS_USE_SCMI_SDS_DRIVER
build option to 1 for Juno.

Change-Id: Idb7e3c6af582f49e332167a2158703c2d781b437
Signed-off-by: Sandrine Bailleux <sandrine.bailleux@arm.com>
plat/arm/board/juno/platform.mk

index fee4391d25f3d76e810d9ee0e44a0b24aac46b98..70d690922b12215c56c06a686997091c5b54d7f4 100644 (file)
@@ -102,6 +102,10 @@ ARM_BOARD_OPTIMISE_MEM             :=      1
 # Do not enable SVE
 ENABLE_SVE_FOR_NS              :=      0
 
+# Select SCMI/SDS drivers instead of SCPI/BOM driver for communicating with the
+# SCP during power management operations and for SCP RAM Firmware transfer.
+CSS_USE_SCMI_SDS_DRIVER                :=      1
+
 include plat/arm/board/common/board_css.mk
 include plat/arm/common/arm_common.mk
 include plat/arm/soc/common/soc_css.mk