libyaml: moved to github
authorNicolas Thill <nico@openwrt.org>
Sat, 18 Apr 2015 23:45:13 +0000 (23:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 18 Apr 2015 23:45:13 +0000 (23:45 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 45500

libs/libyaml/Makefile [deleted file]

diff --git a/libs/libyaml/Makefile b/libs/libyaml/Makefile
deleted file mode 100644 (file)
index 8f26a6b..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2008-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=yaml
-PKG_VERSION:=0.1.6
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://pyyaml.org/download/libyaml/
-PKG_MD5SUM:=5fe00cda18ca5daeb43762b80c38e06e
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS += $(FPIC)
-
-define Package/libyaml
-  SUBMENU:=Python
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=libyaml
-  URL:=http://pyyaml.org/wiki/LibYAML
-endef
-
-define Package/libyaml/description
-  yaml library written in c
-endef
-
-define Package/libyaml/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml.so $(1)/usr/lib/
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml.{a,la} $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libyaml))