tcsh: move to github
authorNuno Goncalves <nunojpg@gmail.com>
Tue, 16 Sep 2014 00:33:22 +0000 (00:33 +0000)
committerNuno Goncalves <nunojpg@gmail.com>
Tue, 16 Sep 2014 00:33:22 +0000 (00:33 +0000)
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
SVN-Revision: 42562

utils/tcsh/Makefile [deleted file]
utils/tcsh/patches/001-gethost [deleted file]
utils/tcsh/patches/002-NLS [deleted file]

diff --git a/utils/tcsh/Makefile b/utils/tcsh/Makefile
deleted file mode 100644 (file)
index 862cfad..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2011 Nuno Goncalves <nunojpg@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=tcsh
-PKG_VERSION:=6.17.00
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.astron.com/pub/tcsh/
-PKG_MD5SUM:=c47de903e3d52f6824c8dd0c91eeb477
-
-PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/tcsh
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Enhanced Berkeley UNIX C shell
-  DEPENDS:=+libncurses
-  URL:=http://www.tcsh.org/
-endef
-
-define Package/tcsh/description
-       Tcsh is an enhanced, but completely compatible
-       version of the Berkeley UNIX C shell (csh). It
-       is a command language interpreter usable both
-       as an interactive login shell and a shell
-       script command processor. It includes a
-       command-line editor, programmable word
-       completion, spelling correction, a history
-       mechanism, job control and a C-like syntax.
-endef
-
-define Package/tcsh/postinst
-#!/bin/sh
-grep tcsh $${IPKG_INSTROOT}/etc/shells || \
-       echo "/bin/tcsh" >> $${IPKG_INSTROOT}/etc/shells
-       echo "/bin/csh" >> $${IPKG_INSTROOT}/etc/shells
-endef
-
-define Package/tcsh/install
-       $(INSTALL_DIR) $(1)/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tcsh $(1)/bin/
-       ln -sf tcsh $(1)/bin/csh
-endef
-
-$(eval $(call BuildPackage,tcsh))
diff --git a/utils/tcsh/patches/001-gethost b/utils/tcsh/patches/001-gethost
deleted file mode 100644 (file)
index 62342e2..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -365,7 +365,7 @@
- gethost:  gethost.c sh.err.h tc.const.h sh.h
-       rm -f gethost
--      ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
-+      gcc -o gethost -g -O2 -I. -I. -D_PATH_TCSHELL='"/usr/local/bin/tcsh"' $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
- tc.defs.c:    gethost host.defs
-       @rm -f $@.tmp
diff --git a/utils/tcsh/patches/002-NLS b/utils/tcsh/patches/002-NLS
deleted file mode 100644 (file)
index 9c52afd..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/config/linux
-+++ b/config/linux
-@@ -106,6 +106,4 @@
- #endif
- #define ECHO_STYLE      BOTH_ECHO
--#define NLS_CATALOGS
--
- #endif /* _h_config */