php5: compile cli/cgi sapi unconditionally
authorMichael Heimpold <mhei@heimpold.de>
Sat, 16 Nov 2013 22:22:28 +0000 (22:22 +0000)
committerMichael Heimpold <mhei@heimpold.de>
Sat, 16 Nov 2013 22:22:28 +0000 (22:22 +0000)
Compiling php without a sapi does not make much sense and often
people forget to choose one of the both openwrt packages. But this
results in a compile error, so it's better to always compile both
sapis.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 38825

lang/php5/Makefile

index 916878a536db9d9aef16ed26f85ef9fa0713654d..41e3543728e500946e9ebd4f6e73a10577654edb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.4.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
@@ -37,7 +37,6 @@ PHP5_MODULES = \
        xml xmlreader xmlwriter zip \
 
 PKG_CONFIG_DEPENDS:= \
-       CONFIG_PACKAGE_php5-cgi CONFIG_PACKAGE_php5-cli \
        $(patsubst %,CONFIG_PACKAGE_php5-mod-%,$(PHP5_MODULES)) \
        CONFIG_PHP5_FILTER CONFIG_PHP5_LIBXML CONFIG_PHP5_SYSTEMTZDATA
 
@@ -124,6 +123,8 @@ define Package/php5-fastcgi/description
 endef
 
 CONFIGURE_ARGS+= \
+       --enable-cli \
+       --enable-cgi \
        --enable-shared \
        --disable-static \
        --disable-rpath \
@@ -139,18 +140,6 @@ CONFIGURE_ARGS+= \
        --with-pcre-regex="$(STAGING_DIR)/usr" \
        --disable-phar
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_php5-cli),)
-  CONFIGURE_ARGS+= --enable-cli
-else
-  CONFIGURE_ARGS+= --disable-cli
-endif
-
-ifneq ($(SDK)$(CONFIG_PACKAGE_php5-cgi),)
-  CONFIGURE_ARGS+= --enable-cgi
-else
-  CONFIGURE_ARGS+= --disable-cgi
-endif
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_php5-mod-calendar),)
   CONFIGURE_ARGS+= --enable-calendar=shared
 else