lxpanel: Override the default config to be more embedded-friendly. Removes the wastef...
authorMichael Büsch <mb@bu3sch.de>
Mon, 27 Sep 2010 22:11:03 +0000 (22:11 +0000)
committerMichael Büsch <mb@bu3sch.de>
Mon, 27 Sep 2010 22:11:03 +0000 (22:11 +0000)
SVN-Revision: 23140

lxde/apps/lxpanel/Makefile
lxde/apps/lxpanel/files/default_config/config [new file with mode: 0644]
lxde/apps/lxpanel/files/default_config/panels/panel [new file with mode: 0644]

index 968e6ccba73331a882172f20745960d15d10d1b1..dd591c25bbd7fe1772dd2799f75c4f782879adda 100644 (file)
@@ -58,6 +58,10 @@ define Package/lxpanel/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/share/lxpanel/* \
                $(1)/usr/share/lxpanel/
+       $(INSTALL_DIR) $(1)/usr/share/lxpanel/profile/default
+       $(CP) \
+               ./files/default_config/* \
+               $(1)/usr/share/lxpanel/profile/default/
 endef
 
 $(eval $(call BuildPackage,lxpanel))
diff --git a/lxde/apps/lxpanel/files/default_config/config b/lxde/apps/lxpanel/files/default_config/config
new file mode 100644 (file)
index 0000000..4c4b3e9
--- /dev/null
@@ -0,0 +1,3 @@
+[Command]
+FileManager=pcmanfm %s
+Terminal=xterm
diff --git a/lxde/apps/lxpanel/files/default_config/panels/panel b/lxde/apps/lxpanel/files/default_config/panels/panel
new file mode 100644 (file)
index 0000000..6ea9d56
--- /dev/null
@@ -0,0 +1,99 @@
+# lxpanel <profile> config file. Manually editing is not recommended.
+# Use preference dialog in lxpanel to adjust config when you can.
+
+Global {
+    edge=bottom
+    allign=left
+    margin=0
+    widthtype=percent
+    width=100
+    height=26
+    transparent=0
+    tintcolor=#000000
+    alpha=0
+    autohide=0
+    heightwhenhidden=2
+    setdocktype=1
+    setpartialstrut=1
+    usefontcolor=0
+    fontcolor=#ffffff
+    background=0
+    backgroundfile=/usr/share/lxpanel/images/background.png
+    iconsize=24
+}
+
+Plugin {
+    type = space
+    Config {
+        Size=2
+    }
+}
+
+Plugin {
+    type = menu
+    Config {
+        image=/usr/share/lxpanel/images/my-computer.png
+        system {
+        }
+        separator {
+        }
+        item {
+            command=run
+        }
+        separator {
+        }
+        item {
+            image=gnome-logout
+            command=logout
+        }
+    }
+}
+
+Plugin {
+    type = space
+    Config {
+        Size=4
+    }
+}
+
+Plugin {
+    type = pager
+}
+
+Plugin {
+    type = space
+    Config {
+        Size=4
+    }
+}
+
+Plugin {
+    type = taskbar
+    expand=1
+    Config {
+        tooltips=1
+        IconsOnly=0
+        ShowAllDesks=0
+        UseMouseWheel=1
+        UseUrgencyHint=1
+        FlatButton=0
+        MaxTaskWidth=150
+        spacing=1
+        GroupedTasks=0
+    }
+}
+
+Plugin {
+    type = tray
+}
+
+Plugin {
+    type = dclock
+    Config {
+        ClockFmt=%R
+        TooltipFmt=%A %x
+        BoldFont=0
+        IconOnly=0
+    }
+}
+