[packages_10.03.2] rsync: merge r27238, r28906, r29526
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:05:38 +0000 (16:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:05:38 +0000 (16:05 +0000)
SVN-Revision: 30254

net/rsync/Makefile
net/rsync/files/rsyncd.init

index 46670e57610486b0e0b07d346dc2d0cd192ee22e..650b6610bb3104dc73103b6617ba736886d5ba80 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
-PKG_VERSION:=3.0.8
-PKG_RELEASE:=3
+PKG_VERSION:=3.0.9
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
-PKG_MD5SUM:=0ee8346ce16bdfe4c88a236e94c752b4
+PKG_MD5SUM:=5ee72266fe2c1822333c407e1761b92b
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
index 741e09c3438cebb07ae8b6621b224a9e467919f4..fdbc0166236a309d05144df1b6c57de965954c41 100644 (file)
@@ -2,14 +2,13 @@
 # Copyright (C) 2011 OpenWrt.org
 
 START=50
-BIN=/usr/bin/rsync
-PID=/var/run/rsyncd.pid
-SSD=start-stop-daemon
+
+SERVICE_PID_FILE=/var/run/rsyncd.pid
 
 start() {
-       $SSD -p $PID -S -x $BIN -- --daemon
+       service_start /usr/bin/rsync --daemon
 }
 
 stop() {
-       $SSD -p $PID -K
+       service_stop /usr/bin/rsync
 }