lantiq: fix xway image building
authorLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:36:33 +0000 (22:36 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:36:33 +0000 (22:36 +0000)
Commit 8c130dd (lantiq: use new image build process for some images) broke
image generation for the xway target since the generated macros reference not
existing WBMRA.dts and WBMRB.dts files leading to the following build error:

  mips-openwrt-linux-musl-cpp: error: ../dts/WBMRA.dts: No such file or directory
  mips-openwrt-linux-musl-cpp: warning: '-x assembler-with-cpp' after last input file has no effect
  mips-openwrt-linux-musl-cpp: fatal error: no input files

Previously both the WBMRA and WBMRB profiles shared a common WBMR DT since
the only difference is the embedded firmware kmod package.

Extend the lantiqImage macro to optionally support specifying a different
DTS file and use this facility to let the both WBMR profiles reference the
correct device tree file.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
SVN-Revision: 49330

target/linux/lantiq/image/Makefile

index 033dcc32b48a569abb20cdee06c0171dc1f98eed..bc74e4f6979eee91bdc34733478be69ea504072e 100644 (file)
@@ -314,7 +314,7 @@ define lantiqImage
   define Device/$(1)
     $$(Device/lantiqImage)
     DEVICE_PROFILE := $(1)
-    DEVICE_DTS := $(1)
+    DEVICE_DTS := $(if $(2),$(2),$(1))
   endef
   TARGET_DEVICES += $(1)
 endef
@@ -381,8 +381,8 @@ Image/Build/Profile/DGN3500=$(call Image/BuildDGN3500/$(1),$(1),DGN3500)
 Image/BuildKernel/Profile/DGN3500B=$(call Image/BuildKernel/Template,DGN3500B)
 Image/Build/Profile/DGN3500B=$(call Image/BuildDGN3500B/$(1),$(1),DGN3500B)
 
-$(eval $(call lantiqImage,WBMRA))
-$(eval $(call lantiqImage,WBMRB))
+$(eval $(call lantiqImage,WBMRA,WBMR))
+$(eval $(call lantiqImage,WBMRB,WBMR))
 
 Image/BuildKernel/Profile/FRITZ7320=$(call Image/BuildKernelEVA/Template,FRITZ7320)
 Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)