kernel: crypto: drop kmod-crypto-wq
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Sun, 2 May 2021 09:25:46 +0000 (11:25 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:11:38 +0000 (15:11 +0200)
CONFIG_CRYPTO_WORKQUEUE was removed in upstream commit[1]. This symbol doesn't
exist since kernel 5.3 and this package is empty.

1. [ crypto: cryptd - move kcrypto_wq into cryptd ]
(https://github.com/torvalds/linux/commit/3e56e168638b3e7147902c3b7257a57ea573a30e)

Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
package/kernel/linux/modules/crypto.mk

index 2775239e5270ed72150d8f7d16cd4e4cb7735d37..edce712c565ef32006a8957da6ef5633064a6bb3 100644 (file)
@@ -986,16 +986,6 @@ endef
 $(eval $(call KernelPackage,crypto-user))
 
 
-define KernelPackage/crypto-wq
-  TITLE:=CryptoAPI work queue handling
-  KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
-  FILES:=$(LINUX_DIR)/crypto/crypto_wq.ko
-  AUTOLOAD:=$(call AutoLoad,09,crypto_wq)
-  $(call AddDepends/crypto)
-endef
-$(eval $(call KernelPackage,crypto-wq))
-
-
 define KernelPackage/crypto-xts
   TITLE:=XTS cipher CryptoAPI module
   DEPENDS:=+kmod-crypto-gf128 +kmod-crypto-manager