kernel: bump 4.9 to 4.9.209
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 14 Jan 2020 13:44:24 +0000 (14:44 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:44:38 +0000 (13:44 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.9/022-net-add-devm-version-of-alloc_etherdev_mqs-function.patch
target/linux/layerscape/patches-4.9/301-arch-support-layerscape.patch

index 88649e6309ae74bc7cb66b32cfe6b7ae5bb4cf7a..d9ade3294207c9b9a16748638f2456cc02128432 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .208
+LINUX_VERSION-4.9 = .209
 LINUX_VERSION-4.14 = .162
 
-LINUX_KERNEL_HASH-4.9.208 = b7ad1c9841d671d026c55a4c91c77205f8b488ca5f980f838591c68662e0525a
+LINUX_KERNEL_HASH-4.9.209 = 0258d5bef915fddcdd584a26ae91bafa996d7e400e725d36329ee44041aa59e1
 LINUX_KERNEL_HASH-4.14.162 = f65170224cd4359ce8b2793b492bd8127abdd0b91350484e001bce13f0c98b4b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 6008be38d3daee06a3e5702aa30b621507a54a08..3e367589f91b6e4ae5ed40156267ac05abd204bb 100644 (file)
  
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3926,14 +3926,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3929,14 +3929,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index c5d65b7105ef0ecf1ba256901921b735bee5fa1a..b553dfaa3f1284e29a55b60764ab90a74839b992 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  int eth_gro_complete(struct sk_buff *skb, int nhoff);
 --- a/net/ethernet/eth.c
 +++ b/net/ethernet/eth.c
-@@ -391,6 +391,34 @@ struct net_device *alloc_etherdev_mqs(in
+@@ -396,6 +396,34 @@ struct net_device *alloc_etherdev_mqs(in
  }
  EXPORT_SYMBOL(alloc_etherdev_mqs);
  
index 52dfced2b890fbf77ac9a1530c48148987154f9c..473990ddaa7bc889d6ecf42310065f50ed39af63 100644 (file)
@@ -345,7 +345,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #define PROT_SECT_NORMAL      (PROT_SECT_DEFAULT | PMD_SECT_PXN | PMD_SECT_UXN | PMD_ATTRINDX(MT_NORMAL))
 --- a/arch/arm64/include/asm/pgtable.h
 +++ b/arch/arm64/include/asm/pgtable.h
-@@ -370,6 +370,11 @@ static inline int pmd_protnone(pmd_t pmd
+@@ -366,6 +366,11 @@ static inline int pmd_protnone(pmd_t pmd
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
  #define pgprot_writecombine(prot) \
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)