leon: refresh patches to apply/compile on 5.15
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 18 Aug 2023 07:27:03 +0000 (09:27 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 24 Oct 2023 21:23:22 +0000 (23:23 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/leon/patches-5.15/0016-spi-add-support-for-aeroflex-gaisler-spimctrl.patch
target/linux/leon/patches-5.15/0029-drivers-perf-Add-driver-for-L4STAT-in-GR740-configur.patch

index a403506d9de30fa8277ddba2dd3b61b0e286f8cf..6e4d1f416622928cf0ceb92286811023ff0d7ba0 100644 (file)
@@ -47,9 +47,9 @@ index 6fea5821662e..d7b1c7650e1a 100644
  
  # SPI master controller drivers (bus)
 +obj-$(CONFIG_SPI_SPIMCTRL)            += spi-spimctrl.o
- obj-$(CONFIG_SPI_ALTERA)              += spi-altera.o
- obj-$(CONFIG_SPI_AR934X)              += spi-ar934x.o
- obj-$(CONFIG_SPI_ARMADA_3700)         += spi-armada-3700.o
+ obj-$(CONFIG_SPI_ALTERA)              += spi-altera-platform.o
+ obj-$(CONFIG_SPI_ALTERA_CORE)         += spi-altera-core.o
+ obj-$(CONFIG_SPI_ALTERA_DFL)          += spi-altera-dfl.o
 diff --git a/drivers/spi/spi-spimctrl.c b/drivers/spi/spi-spimctrl.c
 new file mode 100644
 index 000000000000..4d025e54d9d3
index e2b484329a9e5da41ba4faf2de9c70079bc57482..7f9d47a6640249ebe681f409dc80c62bdbe1cf8f 100644 (file)
@@ -182,9 +182,9 @@ index 8188cae9786f..b38222ba3ae7 100644
 --- a/arch/sparc/Kconfig
 +++ b/arch/sparc/Kconfig
 @@ -52,6 +52,7 @@ config SPARC
-       select NEED_DMA_MAP_STATE
-       select NEED_SG_DMA_LENGTH
+        select NEED_SG_DMA_LENGTH
        select SET_FS
+       select TRACE_IRQFLAGS_SUPPORT
 +      select HAVE_PERF_EVENTS
  
  config SPARC32
@@ -308,9 +308,9 @@ index 5365fd56f88f..b64542c520ef 100644
 --- a/drivers/perf/Makefile
 +++ b/drivers/perf/Makefile
 @@ -13,3 +13,4 @@ obj-$(CONFIG_QCOM_L3_PMU) += qcom_l3_pmu.o
- obj-$(CONFIG_THUNDERX2_PMU) += thunderx2_pmu.o
  obj-$(CONFIG_XGENE_PMU) += xgene_pmu.o
  obj-$(CONFIG_ARM_SPE_PMU) += arm_spe_pmu.o
+ obj-$(CONFIG_ARM_DMC620_PMU) += arm_dmc620_pmu.o
 +obj-$(CONFIG_L4STAT_PMU) += l4stat_pmu.o
 diff --git a/drivers/perf/l4stat_pmu.c b/drivers/perf/l4stat_pmu.c
 new file mode 100644