kernel: kmod-lib-zstd: enable crypto API support
authorRui Salvaterra <rsalvaterra@gmail.com>
Tue, 27 Oct 2020 09:42:31 +0000 (09:42 +0000)
committerPaul Spooren <mail@aparcar.org>
Sun, 6 Dec 2020 18:56:59 +0000 (08:56 -1000)
Zstd is supported by the crypto API since Linux 4.18. Enable this feature and
reveal the package in the configuration section, so the user can select it.
This allows zstd to be used as a compression algorithm in zram, for example.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/kernel/linux/modules/lib.mk

index 43d3ca5538f1e597f3e11022b1a427286f4670af..9a341932bdeb3c9816b82eeeecc7114f24615fcc 100644 (file)
@@ -124,16 +124,18 @@ $(eval $(call KernelPackage,lib-lzo))
 define KernelPackage/lib-zstd
   SUBMENU:=$(LIB_MENU)
   TITLE:=ZSTD support
+  DEPENDS:=+kmod-crypto-acompress
   KCONFIG:= \
+       CONFIG_CRYPTO_ZSTD \
        CONFIG_ZSTD_COMPRESS \
        CONFIG_ZSTD_DECOMPRESS \
        CONFIG_XXHASH
-  HIDDEN:=1
   FILES:= \
+       $(LINUX_DIR)/crypto/zstd.ko \
        $(LINUX_DIR)/lib/xxhash.ko \
        $(LINUX_DIR)/lib/zstd/zstd_compress.ko \
        $(LINUX_DIR)/lib/zstd/zstd_decompress.ko
-  AUTOLOAD:=$(call AutoProbe,xxhash zstd_compress zstd_decompress)
+  AUTOLOAD:=$(call AutoProbe,xxhash zstd zstd_compress zstd_decompress)
 endef
 
 define KernelPackage/lib-zstd/description